Bug 221236 - Can you include the latest Asus quirks.c patch in the next kernel release?
Can you include the latest Asus quirks.c patch in the next kernel release?
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-02 23:57 EST by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-27 20:35:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-01-02 23:57:37 EST
Asus motherboards have recently had problems with SMBus functionality. To make a
long story short, ASUS motherboard bioses default to hiding the SMBus. In
response, a patch was originally written back in kernel 2.4 in quirks.c to
uncloak the SMBus. However, this patch ended up conflicting with ACPI support,
so the patch is now removed at the kernel configuration stage whenever ACPI
support is used.

Since the Fedora kernels turn on ACPI support, as a result the SMBus is not
available for ASUS motherboards running on Fedora stock kernels.

Luckily, a revised patch has recently been developed by Alan Cox that avoids
these problems.
(See the following thread for details: http://lkml.org/lkml/2006/12/4/233)

Would it be possible to include this patch in the next kernel update so that
ASUS motherboard users like myself can use the SMBus functionality?

In particular, I would like to once again use lmsensors which depends on the
SMBus (and I would like to avoid recompiling a custom kernel...)

Thanks
Comment 1 Need Real Name 2007-03-27 20:35:16 EDT
Fixed in kernel 2.6.20...

Note You need to log in before you can comment on or make changes to this bug.