Bug 221254 - meld crash under fc6 while works on fc5
meld crash under fc6 while works on fc5
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pygtk2 (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-03 05:43 EST by Lorenzo Fiorini
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-14 21:42:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 221254 None None None Never

  None (edit)
Description Lorenzo Fiorini 2007-01-03 05:43:04 EST
Description of problem:

meld ~/cvstmp/dir ./dir crash under fully yummed fc6 while it works with fc5 on
the same PC ( two partitions ) and on the same dirs ( fc6 links fc5 dirs )

The error is "size-related" and "dir-related" since meld ~/cvstmp/dir/subdir
./dir/subdir works and meld /etc /tmp works.

Already reported to gnome bugzilla using bugbuddy:
http://bugzilla.gnome.org/show_bug.cgi?id=370575
but they say it can't be a meld problem.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. meld ~/dir ./dir with a CVS dir large enough
2.
3.
  
Actual results:

see bugbuddy below

Expected results:

should work as in fc5

Additional info:

Distribution: Fedora Core release 6 (Zod)
Gnome Release: 2.16.0 2006-09-04 (Red Hat, Inc)
BugBuddy Version: 2.16.0

System: Linux 2.6.18-1.2869.fc6 #1 SMP Wed Dec 20 14:51:19 EST 2006 i686
X Vendor: The X.Org Foundation
X Vendor Release: 70101000
Selinux: No
Accessibility: Enabled
----------- .xsession-errors (17 sec old) ---------------------
winscard_clnt.c:320:SCardEstablishContextTH() Cannot open public shared file:
/var/run/pcscd.pub
GTK Accessibility Module initialized
Bonobo accessibility support initialized
GTK Accessibility Module initialized
Bonobo accessibility support initialized
** (eggcups:2535): WARNING **: IPP request failed with status 1030
GTK Accessibility Module initialized
Introspect error: The name edu.duke.linux.yum was not provided by any .service files
Unable to connect to yum-updatesd.  Please ensure that the yum-updatesd 
package is installed and that the service is running.
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a
timestamp of 0 for 0x3600003 (Evince Doc)
Window manager warning: meta_window_activate called by a pager with a 0
timestamp; the pager needs to be fixed.
GTK Accessibility Module initialized
Bonobo accessibility support initialized
--------------------------------------------------

Memory status: size: 61644800 vsize: 0 resident: 61644800 share: 0 rss: 23429120
rss_rlim: 0
CPU usage: start_time: 1167817926 rtime: 0 utime: 302 stime: 0 cutime:264
cstime: 0 timeout: 38 it_real_value: 0 frequency: 0

Backtrace was generated from '/usr/bin/meld'

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1209043264 (LWP 2699)]
(no debugging symbols found)
...
(no debugging symbols found)
0x0096f402 in __kernel_vsyscall ()
#0  0x0096f402 in __kernel_vsyscall ()
#1  0x006a7c93 in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x07b7ccf6 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x00b845a1 in gtk_tree_sortable_sort_column_changed ()
   from /usr/lib/libgtk-x11-2.0.so.0
#5  0x00b783c9 in gtk_tree_model_get_iter () from /usr/lib/libgtk-x11-2.0.so.0
#6  0x00d44862 in gail_tree_view_new ()
   from /usr/lib/gtk-2.0/modules/libgail.so
#7  0x006fd5e1 in g_source_is_destroyed () from /lib/libglib-2.0.so.0
#8  0x006ff342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#9  0x0070231f in g_main_context_check () from /lib/libglib-2.0.so.0
#10 0x007026c9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#11 0x00a9ac14 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#12 0x00375690 in ?? ()
   from /usr/lib/python2.4/site-packages/gtk-2.0/gtk/_gtk.so
#13 0x068b6f28 in PyEval_EvalFrame () from /usr/lib/libpython2.4.so.1.0
#14 0x068b72dd in PyEval_EvalFrame () from /usr/lib/libpython2.4.so.1.0
#15 0x068b81b5 in PyEval_EvalCodeEx () from /usr/lib/libpython2.4.so.1.0
#16 0x068b6865 in PyEval_EvalFrame () from /usr/lib/libpython2.4.so.1.0
#17 0x068b81b5 in PyEval_EvalCodeEx () from /usr/lib/libpython2.4.so.1.0
#18 0x068b8293 in PyEval_EvalCode () from /usr/lib/libpython2.4.so.1.0
#19 0x068d5078 in Py_CompileString () from /usr/lib/libpython2.4.so.1.0
#20 0x068d67b8 in PyRun_SimpleFileExFlags () from /usr/lib/libpython2.4.so.1.0
#21 0x068d6e9a in PyRun_AnyFileExFlags () from /usr/lib/libpython2.4.so.1.0
#22 0x068dd825 in Py_Main () from /usr/lib/libpython2.4.so.1.0
#23 0x08048582 in main ()

Thread 1 (Thread -1209043264 (LWP 2699)):
#0  0x0096f402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x006a7c93 in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x07b7ccf6 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x00b845a1 in gtk_tree_sortable_sort_column_changed ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#5  0x00b783c9 in gtk_tree_model_get_iter () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#6  0x00d44862 in gail_tree_view_new ()
   from /usr/lib/gtk-2.0/modules/libgail.so
No symbol table info available.
#7  0x006fd5e1 in g_source_is_destroyed () from /lib/libglib-2.0.so.0
No symbol table info available.
#8  0x006ff342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
No symbol table info available.
#9  0x0070231f in g_main_context_check () from /lib/libglib-2.0.so.0
No symbol table info available.
#10 0x007026c9 in g_main_loop_run () from /lib/libglib-2.0.so.0
No symbol table info available.
#11 0x00a9ac14 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#12 0x00375690 in ?? ()
   from /usr/lib/python2.4/site-packages/gtk-2.0/gtk/_gtk.so
No symbol table info available.
#13 0x068b6f28 in PyEval_EvalFrame () from /usr/lib/libpython2.4.so.1.0
No symbol table info available.
#14 0x068b72dd in PyEval_EvalFrame () from /usr/lib/libpython2.4.so.1.0
No symbol table info available.
#15 0x068b81b5 in PyEval_EvalCodeEx () from /usr/lib/libpython2.4.so.1.0
No symbol table info available.
#16 0x068b6865 in PyEval_EvalFrame () from /usr/lib/libpython2.4.so.1.0
No symbol table info available.
#17 0x068b81b5 in PyEval_EvalCodeEx () from /usr/lib/libpython2.4.so.1.0
No symbol table info available.
#18 0x068b8293 in PyEval_EvalCode () from /usr/lib/libpython2.4.so.1.0
No symbol table info available.
#19 0x068d5078 in Py_CompileString () from /usr/lib/libpython2.4.so.1.0
No symbol table info available.
#20 0x068d67b8 in PyRun_SimpleFileExFlags () from /usr/lib/libpython2.4.so.1.0
No symbol table info available.
#21 0x068d6e9a in PyRun_AnyFileExFlags () from /usr/lib/libpython2.4.so.1.0
No symbol table info available.
#22 0x068dd825 in Py_Main () from /usr/lib/libpython2.4.so.1.0
No symbol table info available.
#23 0x08048582 in main ()
No symbol table info available.
#0  0x0096f402 in __kernel_vsyscall ()
Comment 1 Matthew Barnes 2007-02-14 21:42:24 EST
Closing here since this has already been reported upstream.  I'll continue to
track the upstream bug.

Note You need to log in before you can comment on or make changes to this bug.