Bug 221379 - Anaconda assumes installation of GRUB MBR on /dev/hda.
Anaconda assumes installation of GRUB MBR on /dev/hda.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-04 02:52 EST by Robert Case (Arlyle Consulting)
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-04 08:39:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Case (Arlyle Consulting) 2007-01-04 02:52:37 EST
Description of problem:
I run a server with the following configuration:
TYAN S2462 Motherboard
Dual AMD 1900+ MP Processors (1.6GHz)
Adaptec 29160 SCSI controller (built onto the motherboard)
ATA Controller built onto the motherboard
1 Seagate Cheetah 18GB SCSI Drive
1 Seagate Cheetah 36GB SCSI Drive
1 Pioneer DVD-ROM Drive (connected to the Primary ATA port at Master)
1 1.44MB Floppy Drive
2GB RAM

The BIOS is configured to boot CD-ROM first, then the SCSI disks, then the IDE
(ATA) drives.

I've been running this server with this configuration for about 4 years with no
problems.

I'm undertaking a project which will require me to add a significant amount of
disk space without spending a whole lot of money.  So I added a Seagate
Barracuda 300GB ATA hard drive, connecting to the Secondary ATA port at Master.

Then I decided to upgrade the OS (it was still running RH7.3).  Since it was so
out of date, I decided to do a fresh install of FC6.

When I get to the part to configure GRUB, the first choice is "The GRUB boot
loader will be installed on /dev/hda."  The only other choice is to not install
a boot loader.  I do not want to have GRUB installed on the IDE drive because
that is not how the system functions.  It has always booted from the SCSI
system, it works well this way, and I don't want to change it.

This also happens if you do an upgrade, and you choose to change the boot loader
configuration.

I'm installing from a DVD that I burned from the ISO file and booting it in a
DVD-ROM drive.  The media test passes.

Version-Release number of selected component (if applicable):
N/A

How reproducible:
Everytime.

Steps to Reproduce:
1.  Configure a system, outfitted with SCSI, to boot the CD-ROM first, then
SCSI, then IDE in the BIOS.
2.  Boot the installation DVD, and proceed with the installation process.
3.  When you get to the part where it asks about the GRUB boot loader, choose to
"Create new boot loader configuration", and click "Next".
  
Actual results:
There are only two choices; either intall GRUB on /dev/hda (the ATA disk), or
"No boot loader will be installed.", neither of which are appropriate to my
system configuration.  Anaconda is assuming the IDE drive will be the primary
boot disk, and that is a false assumption on my system.

Expected results:
There should be a choice of which disk to install the GRUB boot loader.  Perhaps
a drop-down list next to the "The GRUB boot loader will be installed on..."
text.  It's okay if that drop-down defaults to "/dev/hda", but not having a
choice is not good in this situation.

Additional info:
I understand that most motherboards will be inclined to boot to the IDE/ATA
drive before any other, but most BIOSes also have the option to specify the boot
order, like mine does.

The only workaround was to physically disconnect the IDE/ATA drive data cable
and rerun Anaconda.
Comment 1 Jeremy Katz 2007-01-04 08:39:38 EST
If you select to see the advanced bootloader configuration, then you can adjust
the drive order to match that provided by the BIOS.  Unfortunately, BIOSes don't
export this information for later probing/use.

Note You need to log in before you can comment on or make changes to this bug.