Bug 221468 - /etc/apcupsd action scripts should be marked noreplace
/etc/apcupsd action scripts should be marked noreplace
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: apcupsd (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-04 13:47 EST by Leigh Koven
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 3.12.4-3.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-05 13:36:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to mark action scripts as noreplace (1.01 KB, patch)
2007-01-04 13:47 EST, Leigh Koven
no flags Details | Diff

  None (edit)
Description Leigh Koven 2007-01-04 13:47:36 EST
Description of problem:
We modified a few of the action scripts (such as mainsback and offbattery) to
fit our needs. When I updated from extras, the RPM overwrote the changed scripts
(only backing one up -- mainsback.rpmsave -- go figure). Since I don't think
it's unreasonable to think that the end-user would want to change those scripts
(after all, that's what they're there for), I suggest the spec be modified to
mark those files as nochange. I've attached a patch which makes the appropriate
changes to the spec file.  

Version-Release number of selected component (if applicable):
3.12.4-2
Comment 1 Leigh Koven 2007-01-04 13:47:36 EST
Created attachment 144830 [details]
Patch to mark action scripts as noreplace
Comment 2 Orion Poplawski 2007-01-05 13:36:39 EST
Thanks.  Fixed in 3.12.4-3.fc5

Note You need to log in before you can comment on or make changes to this bug.