Bug 221470 - AttributeError: YumBaseError instance has no attribute 'value'
AttributeError: YumBaseError instance has no attribute 'value'
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 221647 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-04 13:56 EST by Orion Poplawski
Modified: 2014-01-21 17:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-04 16:46:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2007-01-04 13:56:47 EST
Description of problem:

# yum -y install kernel-debuginfo --enablerepo=updates-debuginfo
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
updates-debuginfo         100% |=========================|  951 B    00:00
skype                     100% |=========================|  951 B    00:00
macromedia                100% |=========================|  951 B    00:00
livna                     100% |=========================| 1.1 kB    00:00
updates-testing           100% |=========================| 1.2 kB    00:00
core                      100% |=========================| 1.1 kB    00:00
updates                   100% |=========================| 1.2 kB    00:00
CoRA                      100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================|  75 kB    00:02
################################################## 295/295
Excluding Packages from Fedora Core 6 - i386 - Test Updates
Finished
Excluding Packages from Fedora Core 6 - i386 - Updates
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kernel-debuginfo.i686 0:2.6.18-1.2869.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: kernel-debuginfo-common-i686 = 2.6.18-1.2869.fc6 for
package: kernel-debuginfo
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package kernel-debuginfo-common.i686 0:2.6.18-1.2869.fc6 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 kernel-debuginfo        i686       2.6.18-1.2869.fc6  updates-debuginfo  156 M
Installing for dependencies:
 kernel-debuginfo-common  i686       2.6.18-1.2869.fc6  updates-debuginfo   27 M

Transaction Summary
=============================================================================
Install      2 Package(s)
Update       0 Package(s)
Remove       0 Package(s)

Total download size: 183 M
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 176, in main
    exFatal(e)
  File "/usr/share/yum-cli/yummain.py", line 55, in exFatal
    logger.critical('\n\n%s', str(e))
  File "/usr/lib/python2.4/site-packages/yum/Errors.py", line 27, in __str__
    return self.value
AttributeError: YumBaseError instance has no attribute 'value'

Version-Release number of selected component (if applicable):
yum-3.0.2-1.fc6

I was able to install oprofile just a little earlier.

If I try to install with rpm:

Preparing...                ########################################### [100%]
        installing package kernel-debuginfo-2.6.18-1.2869.fc6 needs 337MB on the
/ filesystem
Comment 1 Jeremy Katz 2007-01-04 16:46:38 EST
Fixed in upstream cvs for 3.0.3 (which will be what I'll push out for the Fedora
update)
Comment 2 Jeremy Katz 2007-01-05 16:27:34 EST
*** Bug 221647 has been marked as a duplicate of this bug. ***
Comment 3 Jesse Keating 2007-01-14 12:03:08 EST
Confirmed, fixed in 3.0.3.

Note You need to log in before you can comment on or make changes to this bug.