Bug 221553 - lpfc options not persistent with /etc/modprobe.conf
lpfc options not persistent with /etc/modprobe.conf
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-04 21:50 EST by erik tapang
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-09 15:52:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description erik tapang 2007-01-04 21:50:36 EST
Description of problem:
lpfc driver options not persistent via modprobe.conf
to suppress messages like this:

lpfc 0000:08:01.0: 0:1305 Link Down Event x6e received Data: x6e xd x10110
lpfc 0000:08:01.0: 0:1303 Link Up Event x6f received Data: x6f x0 x10 x62
lpfc 0000:08:01.0: 0:1305 Link Down Event x70 received Data: x70 xd x10110
lpfc 0000:08:01.0: 0:1303 Link Up Event x71 received Data: x71 x0 x10 x62

Version-Release number of selected component (if applicable):
filename:       /lib/modules/2.6.9-42.ELsmp/kernel/drivers/scsi/lpfc/lpfc.ko
version:        0:8.0.16.27 2BDE68EAC48EA9D89060BF1

How reproducible:
always on an IBM BladeCenter H21 machine (Xeon)

Steps to Reproduce:
1. edit /etc/modprobe.conf for the options
2. reboot
3.
  
Actual results:

lpfc 0000:08:01.0: 0:1305 Link Down Event x6e received Data: x6e xd x10110
lpfc 0000:08:01.0: 0:1303 Link Up Event x6f received Data: x6f x0 x10 x62
lpfc 0000:08:01.0: 0:1305 Link Down Event x70 received Data: x70 xd x10110
lpfc 0000:08:01.0: 0:1303 Link Up Event x71 received Data: x71 x0 x10 x62

Expected results:

as produced by manually running "modprobe lpfc lpfc_link_speed=2"

Additional info:

filename:       /lib/modules/2.6.9-42.ELsmp/kernel/drivers/scsi/lpfc/lpfc.ko
version:        0:8.0.16.27 2BDE68EAC48EA9D89060BF1
author:         Emulex Corporation - tech.support@emulex.com
description:    Emulex LightPulse Fibre Channel SCSI driver 8.0.16.27

when the fiber cables were plugged in, i see Link Down/Up Events log messages
over and over again. the IBM guys tried setting the FC link speed to 2Gb
in the bios - no effect.
i then manually set it via:

rmmod lpfc
modprobe lpfc lpfc_link_speed=2

that fixed it and  our Storage admin was able to allocate EMC LUNs to the
system.

the problem is that the options can't be made persistent via /etc/modprobe.conf:

options lpfc lpfc_link_speed=2  lpfc_max_luns=10
Comment 1 erik tapang 2007-01-08 09:07:05 EST
stupid mistake on my part - post install script of my kickstart file is using
the wrong initrd name.
please close. not a bug.

Note You need to log in before you can comment on or make changes to this bug.