This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 221564 - smartctl is unable to detect IDE type on SATA
smartctl is unable to detect IDE type on SATA
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: smartmontools (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-05 02:25 EST by Milan Kerslager
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-05 03:22:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2007-01-05 02:25:41 EST
I have MV88SX5081 8-port SATA I PCI-X controller with 7 SATA discs (WDC
WD4000KD-00N) connected using sata_mv module.

# smartctl -a /dev/sda
smartctl version 5.36 [i686-redhat-linux-gnu] Copyright (C) 2002-6 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

Device: ATA      WDC WD4000KD-00N Version: 01.0
Serial number:      WD-WMAMY1131214
Device type: disk
Local Time is: Fri Jan  5 08:21:15 2007 CET
Device does not support SMART

Error Counter logging not supported

[GLTSD (Global Logging Target Save Disable) set. Enable Save with '-S on']
Device does not support Self Test logging

The suggested option '-S on' does not work. When trying to start smatrd, there
is a suggestion in /var/log/messages to use '-s on' which does not work too:

Jan  5 08:07:50 bacula smartd[6184]: Device: /dev/sda, IE (SMART) not enabled,
skip device Try 'smartctl -s on /dev/sdf' to turn on SMART features

# cat /etc/smartd.conf
DEVICESCAN -a -m root -M daily -s
(O/../.././(00|06|12|18)|S/../.././(03|09|15|21)|L/../.././01)

This seems that ATA over SATA detection does not work in smartmontools-5.36-3.
Comment 1 Milan Kerslager 2007-01-05 02:35:50 EST
Even I'm able to run tests and see finished selftest in the disc's logs by using
'-d ata' (see below), I'm unable to force smartd to monitor SATA drives:

# smartctl -d ata -t short /dev/sda

I added '-d ata' to the DEVICESCAN line to the /etc/smartd.conf (the only line
in the config file, see above) but smartd reported zero monitored devices in
/var/log/messages. There is something completly broken :-(

Is there newer package somewhere? I see rhel5-rc1 in the Bugzilla but nowhere in
RHN.
Comment 2 Tomas Mraz 2007-01-05 03:22:10 EST
The autodetection of SATA disks is not implemented yet as well as -d ata on
DEVICESCAN lines. This would require non-trivial changes in smartmontools code
and as such it must be fixed upstream first.
Comment 3 Milan Kerslager 2007-01-05 08:04:35 EST
I see "backported SATA disk detection from upstream" in
smartmontools-5.36-3.2.fc6.src.rpm since Nov 7 2006. So I don't underestand
where the problem is.
Comment 4 Tomas Mraz 2007-01-05 08:55:38 EST
The backported SATA detection is just for detecting that the drive is SATA with
current kernels and printing the error message that -d ata must be used. It
should work with 5.36-3.1.el5 on RHEL5. 

But unfortunately this doesn't mean that the DEVICESCAN or full autodetection
and automatic switching to the -d ata driver is implemented.

Note You need to log in before you can comment on or make changes to this bug.