Bug 221643 - magic file causes PHP warning
magic file causes PHP warning
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: file (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Smetana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-05 15:01 EST by William Yardley
Modified: 2008-05-27 05:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-27 05:24:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Yardley 2007-01-05 15:01:13 EST
Description of problem:
The following lines in /usr/share/magic / /usr/share/file/magic:
# update to distinguish from *.vcf files#0      regex                           
# [^'"]BEGIN[[:space:]]*[{]       awk script text                               

appear to generate PHP warnings in certain circumstances:
PHP Warning:  mime_magic: type regex  BEGIN[[:space:]]*[{] application/x-awk  
invalid in Unknown on line 0

(I believe it also generates a warning with other programs that use this file)

Version-Release number of selected component (if applicable):
file-4.17-8
Comment 1 Tomas Smetana 2007-12-11 06:51:35 EST
So you're saying that PHP can't parse the magic file correctly?  I really don't
think there is something to fix on file's side.
Comment 2 William Yardley 2007-12-11 20:41:51 EST
(In reply to comment #1)
> So you're saying that PHP can't parse the magic file correctly?  I really don't
> think there is something to fix on file's side.

Well it's a year later, so I don't remember that well (and to be honest, I don't
understand the way the magic file works well enough to know if the issue is with
a syntax error in the file, or with PHP not parsing it properly). I do seem to
remember (based on the comment above) that there were some other applications
barfing on this.

btw, the hash mark / comment at the beginning of the line is ours, so in the
actual file as distributed by Red Hat, that's not there.

Ultimately, if you believe the issue is with another component, feel free to
move this bug there. I created the bug under file since I believed the problem
was with the magic file, and since that package owns that file.
Comment 3 Tomas Smetana 2008-05-27 05:24:11 EDT
A forgotten bugreport...  Based on comment #2 -- closing.

Note You need to log in before you can comment on or make changes to this bug.