Bug 221707 - Update conflicts with fresh install
Summary: Update conflicts with fresh install
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: frysk (Show other bugs)
(Show other bugs)
Version: 6
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Stepan Kasal
QA Contact: Len DiMaggio
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-06 14:08 UTC by Adam Huffman
Modified: 2007-11-30 22:11 UTC (History)
9 users (show)

Fixed In Version: 0.0.1.2007.02.07.rh1-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-06 14:40:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Huffman 2007-01-06 14:08:57 UTC
Description of problem:
Yesterday I installed two x86_64 machines.  In both cases both i686 and x86_64
versions of frysk were installed by anaconda.

The latest update only includes the x86_64 version and the transaction test of a
yum update run reports file conflicts:


Transaction Check Error:   file /usr/share/man/man1/ftrace.1.gz from install of
frysk-0.0.1.2006.12.22.rh1-1.fc6 conflicts with file from package
frysk-0.0.1.2006.10.02.rh1-1.fc6
  file /usr/share/man/man8/funit-child.8.gz from install of
frysk-0.0.1.2006.12.22.rh1-1.fc6 conflicts with file from package
frysk-0.0.1.2006.10.02.rh1-1.fc6
  file /usr/share/man/man8/funit-exec.8.gz from install of
frysk-0.0.1.2006.12.22.rh1-1.fc6 conflicts with file from package
frysk-0.0.1.2006.10.02.rh1-1.fc6
  file /usr/share/man/man8/funit-threads.8.gz from install of
frysk-0.0.1.2006.12.22.rh1-1.fc6 conflicts with file from package
frysk-0.0.1.2006.10.02.rh1-1.fc6
  file /usr/share/man/man8/funit.8.gz from install of
frysk-0.0.1.2006.12.22.rh1-1.fc6 conflicts with file from package
frysk-0.0.1.2006.10.02.rh1-1.fc6

Version-Release number of selected component (if applicable):
0.0.1.2006.10.02.rh1-1 (initial version)
0.0.1.2006.12.22.rh1-1 (update version)

How reproducible:
Every time

Steps to Reproduce:
1. run yum update on a freshly installed x86_64 machine
2.
3.
  
Actual results:
Transaction aborted with file conflicts

Expected results:
Transaction proceeds as normal

Additional info:

Comment 1 joebob 2007-01-15 17:16:27 UTC
same problem here on x_86_64.  After updating, the 'frysk package' is the only
one that remains in the package updater.  It states its available, but when I
apply this update I get the following almost identical error as above.  

[('file /usr/share/man/man1/ftrace.1.gz from install of
frysk-0.0.1.2006.12.22.rh1-1.fc6 conflicts with file from package
frysk-0.0.1.2006.10.02.rh1-1.fc6', (7, '/usr/share/man/man1/ftrace.1.gz', 0L)),
('file /usr/share/man/man8/funit-child.8.gz from install of
frysk-0.0.1.2006.12.22.rh1-1.fc6 conflicts with file from package
frysk-0.0.1.2006.10.02.rh1-1.fc6', (7, '/usr/share/man/man8/funit-child.8.gz',
0L)), ('file /usr/share/man/man8/funit-exec.8.gz from install of
frysk-0.0.1.2006.12.22.rh1-1.fc6 conflicts with file from package
frysk-0.0.1.2006.10.02.rh1-1.fc6', (7, '/usr/share/man/man8/funit-exec.8.gz',
0L)), ('file /usr/share/man/man8/funit-threads.8.gz from install of
frysk-0.0.1.2006.12.22.rh1-1.fc6 conflicts with file from package
frysk-0.0.1.2006.10.02.rh1-1.fc6', (7, '/usr/share/man/man8/funit-threads.8.gz',
0L)), ('file /usr/share/man/man8/funit.8.gz from install of
frysk-0.0.1.2006.12.22.rh1-1.fc6 conflicts with file from package
frysk-0.0.1.2006.10.02.rh1-1.fc6', (7, '/usr/share/man/man8/funit.8.gz', 0L))]

Comment 2 Michel Alexandre Salim 2007-01-18 18:25:43 UTC
Looking at the number of Red Hat emails on the Cc list, could someone push the
i386 update to the x86_64 repository?

Comment 3 Andrew Cagney 2007-01-18 18:42:57 UTC
Stepan, your multi-arch RPM changes should fix this.

Comment 4 Daniel Qarras 2007-01-28 09:32:06 UTC
Me too! Same problem here with x86_86/frysk.

Comment 5 Stepan Kasal 2007-11-06 14:40:08 UTC
The problem was fixed in frysk-0.0.1.2007.02.07.rh1-1.fc6.
The FC6 Updates directory currently contains:
[ ]	frysk-0.0.1.2007.02.07.rh1-1.fc6.i686.rpm
[ ]	frysk-0.0.1.2007.02.07.rh1-1.fc6.x86_64.rpm
[ ]	frysk-devel-0.0.1.2007.02.07.rh1-1.fc6.x86_64.rpm
[ ]	frysk-gnome-0.0.1.2007.02.07.rh1-1.fc6.x86_64.rpm


Note You need to log in before you can comment on or make changes to this bug.