Bug 22173 - Mouse cursor problem with Nvidia TNT2 and XFree 4
Mouse cursor problem with Nvidia TNT2 and XFree 4
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-12 13:22 EST by Carlos Rodrigues
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 08:31:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Rodrigues 2000-12-12 13:22:43 EST
I own a Nvidia TNT2 Ultra from Creative Labs and I'm using the XFree86
4.0.1 drivers and when I move the mouse fast, the cursor changes briefly to
a square (blinks). This doesn't happen if I use the XF86_SVGA server.
If I run the XF86_SVGA server (or reboot to Windows and then back into
Linux) and then run X (using the nv.o driver) this problem does not happen
again until I poweroff the machine and then turn it back on (not a reset,
really poweroff). This also doesn't happen if I use the option SoftCursor
in XF86Config-4.

It is annoying to have to log in as root, run XF86_SVGA, kill it and then
use startx normally as a regular user!
Comment 1 Mike A. Harris 2001-03-06 12:19:23 EST
Try the 4.0.2-11.4.0 release of XFree86 from:
ftp://people.redhat.com/mharris

Does it work for you?
Comment 2 Carlos Rodrigues 2001-03-08 18:23:49 EST
I'm afraid not, it continues to do exactly the same thing.
I've recently tried to use the binary only drivers from nvidia and they don't
exibit this behaviour. In fact, if I run X after running it with nvidia's
drivers, instead of a mouse pointer, what I get is a square made out of random
colored pixels and transparent areas (like a spray), and if I run XF86_SVGA I
get no mouse pointer.
Comment 3 Carlos Rodrigues 2001-03-08 18:26:32 EST
Oh, I forgot to state that it is "run X (with nv_drv.o) after running it with
nvidia's drivers".
Comment 4 Mike A. Harris 2001-03-20 02:39:24 EST
THe XFree86 4.0.3 release may fix this problem for you.  Mark Vojcovich
from mvidia commited many nv driver fixes just prior to the release of
4.0.3, and I believe that it should solve the problem for you.  If not,
please update the bug report so that I know, and I will contact Mark.
Comment 5 Mike A. Harris 2001-03-20 02:43:02 EST
Oops, forgot to tell you where to get it:

ftp://people.redhat.com/mharris
Comment 6 Carlos Rodrigues 2001-03-20 18:26:13 EST
Well, I was hoping that it would be fixed in 4.0.3, but... no. Still the same
problem. What really annoys me is that nvidia's drivers seem to get it right, if
only they were opensource...
Comment 7 Carlos Rodrigues 2001-11-10 08:12:40 EST
The problem still persists with XFree86-4.1.0-3 shipped with RedHat 7.2.
Comment 8 Mike A. Harris 2002-01-23 10:28:59 EST
If you use:  Option "swcursor" in the config file in the Device section,
does the problem go away?
Comment 9 Carlos Rodrigues 2002-01-24 08:31:47 EST
With SWCursor the problem goes away.
I think I'm not very far from the truth by saying this is a initialization 
problem with hardware mouse cursor. As a side note there was recent version of 
nvidia's drivers (1.0-12xx I think) that also showed up this behaviour but 
they seem to have fixed it now.
Comment 10 Mike A. Harris 2002-02-08 20:16:55 EST
I've updated our hardware configuration database to default this
particular card to use "swcursor".  This will appear shortly
in rawhide.  Also, you might want to test the rawhide version of
XFree86 4.2.0 out to see if perhaps the problem is now gone with
the hardware cursor.  If so, I can revert the swcursor option.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.