Bug 22175 - (SOUND CS46XX)Sound Fails to Work on ThinkPad 600x after Upgrade to 7.0
(SOUND CS46XX)Sound Fails to Work on ThinkPad 600x after Upgrade to 7.0
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2000-12-12 13:33 EST by CJeness
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:38:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description CJeness 2000-12-12 13:33:54 EST
I did a "fresh" install on my ThinkPad 600x of RedHat 7.0.  The
installation correctly detected the sound card (Crystal Audio Fusion);
however, no sound is actually played.  I have tried using the same
"modules.conf" entries that worked under 6.2 without any success.
Comment 1 Bill Nottingham 2000-12-12 13:41:24 EST
lspci -v output?
Comment 2 CJeness 2000-12-12 14:26:59 EST
00:00.0 Host bridge: Intel Corporation 440BX/ZX - 82443BX/ZX Host bridge (rev
	Flags: bus master, medium devsel, latency 64
	Memory at 40000000 (32-bit, prefetchable)
	Capabilities: [a0] AGP version 1.0

00:01.0 PCI bridge: Intel Corporation 440BX/ZX - 82443BX/ZX AGP bridge (rev 03)
(prog-if 00 [Normal decode])
	Flags: bus master, 66Mhz, medium devsel, latency 168
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=176
	I/O behind bridge: 0000d000-0000dfff
	Memory behind bridge: 70000000-dfffffff
	Prefetchable memory behind bridge: e0000000-f7ffffff

00:02.0 CardBus bridge: Texas Instruments PCI1450 (rev 03)
	Subsystem: IBM: Unknown device 0130
	Flags: bus master, medium devsel, latency 168, IRQ 11
	Memory at 50103000 (32-bit, non-prefetchable)
	Bus: primary=00, secondary=02, subordinate=04, sec-latency=176
	I/O window 0: 00000000-00000003
	I/O window 1: 00000000-00000003
	16-bit legacy interface ports at 0001

00:02.1 CardBus bridge: Texas Instruments PCI1450 (rev 03)
	Subsystem: IBM: Unknown device 0130
	Flags: bus master, medium devsel, latency 168, IRQ 11
	Memory at 50102000 (32-bit, non-prefetchable)
	Bus: primary=00, secondary=05, subordinate=07, sec-latency=176
	Memory window 0: 60008000-6000d000 (prefetchable)
	I/O window 0: 00000200-0000027f
	I/O window 1: 00000000-00000003
	16-bit legacy interface ports at 0001

00:03.0 Communication controller: Lucent Microelectronics WinModem 56k (rev 01)
	Subsystem: IBM: Unknown device 018c
	Flags: bus master, medium devsel, latency 0, IRQ 11
	Memory at 50101000 (32-bit, non-prefetchable)
	I/O ports at 4500
	I/O ports at 4400
	Capabilities: [f8] Power Management version 2

00:06.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24 [CrystalClear
SoundFusion Audio Accelerator] (rev 01)
	Subsystem: IBM: Unknown device 0153
	Flags: bus master, slow devsel, latency 64, IRQ 11
	Memory at 50100000 (32-bit, non-prefetchable)
	Memory at 50000000 (32-bit, non-prefetchable)
	Capabilities: [40] Power Management version 2

00:07.0 Bridge: Intel Corporation 82371AB PIIX4 ISA (rev 02)
	Flags: bus master, medium devsel, latency 0

00:07.1 IDE interface: Intel Corporation 82371AB PIIX4 IDE (rev 01) (prog-if 80
	Flags: bus master, medium devsel, latency 48
	I/O ports at fcf0

00:07.2 USB Controller: Intel Corporation 82371AB PIIX4 USB (rev 01) (prog-if 00
	Flags: bus master, medium devsel, latency 0, IRQ 11
	I/O ports at 4000

00:07.3 Bridge: Intel Corporation 82371AB PIIX4 ACPI (rev 03)
	Flags: medium devsel

01:00.0 VGA compatible controller: Neomagic Corporation NM2360 [MagicMedia
256ZX] (prog-if 00 [VGA])
	Subsystem: IBM: Unknown device 0152
	Flags: bus master, medium devsel, latency 128, IRQ 11
	Memory at e0000000 (32-bit, prefetchable)
	Memory at 70000000 (32-bit, non-prefetchable)
	Memory at 70400000 (32-bit, non-prefetchable)
	Capabilities: [dc] Power Management version 1

05:00.0 Ethernet controller: Xircom Cardbus Ethernet 10/100 (rev 03)
	Subsystem: IBM: Unknown device 8181
	Flags: bus master, medium devsel, latency 64, IRQ 11
	I/O ports at 0200
	Memory at 6000d000 (32-bit, non-prefetchable)
	Memory at 6000c000 (32-bit, non-prefetchable)
	Expansion ROM at 60008000 [disabled]
	Capabilities: [dc] Power Management version 1

Comment 3 Bill Nottingham 2000-12-12 17:11:01 EST
What happens if you do:

modprobe cs46xx thinkpad=1

Does it then work better?

Comment 4 CJeness 2000-12-12 20:17:53 EST
issuing the "modprobe cs46xx thinkpad=1" does not make any difference.  I still
do not here any 
sound at all.
Comment 5 CJeness 2000-12-12 20:21:26 EST
I did mean "hear" and not "here".  Also, I have turned my volume up to the
Comment 6 Bill Nottingham 2000-12-13 11:17:20 EST
Hm. What about:

modprobe -r cs46xx
modprobe cs46xx thinkpad=1 external_amp=1
Comment 7 CJeness 2000-12-13 13:22:04 EST
The suggested commands do not resolve the sound issue.  There is still no
sound.  I also did an "lsmod" after issuing the commands and see the following:

Module                  Size  Used by
cs46xx                 70208   0  (unused)
soundcore               2596   2  [cs46xx]
ac97_codec              7012   0  [cs46xx]
ide-cd                 23628   0  (autoclean)
tulip_cb               32596   2 
cb_enabler              2376   2  [tulip_cb]
ds                      6280   2  [cb_enabler]
i82365                 21668   2 
pcmcia_core            44160   0  [cb_enabler ds i82365]
lockd                  31176   1  (autoclean)
sunrpc                 52964   1  (autoclean) [lockd]
agpgart                18600   0  (unused)
usb-uhci               19052   0  (unused)
usbcore                42088   1  [usb-uhci]
Comment 8 Bill Nottingham 2000-12-13 15:04:08 EST
What do you get if you run 'dmesg'?
Comment 9 CJeness 2000-12-13 16:12:05 EST
Output from dmesg is given below.  One thing that has puzzled me is that the
ethernet card, USB and the sound card seem to be always put on the same
interrupt; i.e., 11.  

Linux version 2.2.16-22 (root@porky.devel.redhat.com) (gcc version egcs-2.91.66
19990314/Linux (egcs-1.1.2 release)) #1 Tue Aug 22 16:49:06 EDT 2000
Detected 498284 kHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 992.87 BogoMIPS
Memory: 63944k/66556k available (1048k kernel code, 412k reserved, 1088k data,
64k init, 0k bigmem)
Dentry hash table entries: 262144 (order 9, 2048k)
Buffer cache hash table entries: 65536 (order 6, 256k)
Page cache hash table entries: 16384 (order 4, 64k)
VFS: Diskquotas version dquot_6.4.0 initialized
CPU: Intel Pentium III (Coppermine) stepping 03
Checking 386/387 coupling... OK, FPU using exception 16 error reporting.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.35a (19990819) Richard Gooch (rgooch@atnf.csiro.au)
PCI: PCI BIOS revision 2.10 entry at 0xfd880
PCI: Using configuration type 1
PCI: Probing PCI hardware
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
TCP: Hash tables configured (ehash 65536 bhash 65536)
Linux IP multicast router 0.06 plus PIM-SM
Initializing RT netlink socket
Starting kswapd v 1.5 
Detected PS/2 Mouse Port.
Serial driver version 4.27 with MANY_PORTS MULTIPORT SHARE_IRQ enabled
pty: 256 Unix98 ptys configured
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.13)
Real Time Clock Driver v1.09
RAM disk driver initialized:  16 RAM disks of 4096K size
PIIX4: IDE controller on PCI bus 00 dev 39
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xfcf0-0xfcf7, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xfcf8-0xfcff, BIOS settings: hdc:DMA, hdd:pio
hda: IBM-DARA-212000, ATA DISK drive
hdc: CRN-8241B, ATAPI CDROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: IBM-DARA-212000, 11509MB w/418kB Cache, CHS=1559/240/63
Floppy drive(s): fd0 is 1.44M
FDC 0 is a National Semiconductor PC87306
md driver 0.90.0 MAX_MD_DEVS=256, MAX_REAL=12
raid5: measuring checksumming speed
raid5: MMX detected, trying high-speed MMX checksum routines
   pII_mmx   :  1108.710 MB/sec
   p5_mmx    :  1164.336 MB/sec
   8regs     :   856.107 MB/sec
   32regs    :   479.679 MB/sec
using fastest function: p5_mmx (1164.336 MB/sec)
scsi : 0 hosts.
scsi : detected total.
md.c: sizeof(mdp_super_t) = 4096
Partition check:
 hda: hda1 hda2 hda3 < hda5 hda6 hda7 hda8 >
autodetecting RAID arrays
autorun ...
... autorun DONE.
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 64k freed
Adding Swap: 264560k swap-space (priority -1)
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.232$ time 16:53:56 Aug 22 2000
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: Intel USB controller: setting latency timer to 0
usb-uhci.c: USB UHCI at I/O 0x4000, IRQ 11
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
usb.c: USB new device connect, assigned device number 1
hub.c: USB hub found
hub.c: 2 ports detected
Crystal 4280/461x + AC97 Audio, version 0.09, 16:52:39 Aug 22 2000
cs461x: Card found at 0x50100000 and 0x50000000, IRQ 11
cs461x: Thinkpad 600X/A20/T20 at 0x50100000/0x50000000, IRQ 11
ac97_codec: AC97 Audio codec, vendor id1: 0x4352, id2: 0x5913 (Cirrus Logic
cs461x: Found 1 audio device(s).
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 28M
agpgart: Detected Intel 440BX chipset
agpgart: AGP aperture is 64M @ 0x40000000
Linux PCMCIA Card Services 3.1.19
  kernel build: 2.2.16-22 #1 Tue Aug 22 16:49:06 EDT 2000
  options:  [pci] [cardbus] [apm]
PCI routing table version 1.0 at 0xf9d00
  00:02.0 -> irq 11
  00:02.1 -> irq 11
Intel PCIC probe: 
  TI 1450 rev 03 PCI-to-CardBus at slot 00:02, mem 0x50103000
    host opts [0]: [ring] [serial pci & irq] [pci irq 11] [lat 168/176] [bus
    host opts [1]: [ring] [serial pci & irq] [pci irq 11] [lat 168/176] [bus
    ISA irqs (scanned) = 3,4,5,7,9,10 PCI status changes
cs: cb_alloc(bus 5): vendor 0x115d, device 0x0003
cs: IO port probe 0x0c00-0x0cff: excluding 0xcf8-0xcff
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x3b8-0x3df 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
ROM image dump:
  image 0: 0x000000-0xffffffff, signature PCIR
cs: cb_config(bus 5)
  fn 0 bar 1: io 0x200-0x27f
  fn 0 bar 2: mem 0x6000d000-0x6000d7ff
  fn 0 bar 3: mem 0x6000c000-0x6000c7ff
  fn 0 rom: mem 0x60008000-0x6000bfff
  irq 11
cs: cb_enable(bus 5)
  bridge io map 0 (flags 0x21): 0x200-0x27f
  bridge mem map 0 (flags 0x1): 0x60008000-0x6000dfff
tulip_attach(device 05:00.0)
tulip.c:v0.91g-ppc 7/16/99 becker@cesdis.gsfc.nasa.gov (modified by
danilo@cs.uni-magdeburg.de for XIRCOM CBE, fixed by Doug Ledford)
eth0: Xircom Cardbus Adapter (DEC 21143 compatible mode) rev 3 at 0x200,
00:10:A4:A8:C6:21, IRQ 11.
eth0:  MII transceiver #0 config 3100 status 7809 advertising 01e1.
hdc: ATAPI 24X CD-ROM drive, 128kB Cache
Uniform CD-ROM driver Revision: 3.10
Comment 10 Bill Nottingham 2001-01-15 11:51:23 EST
Hm. There's nothing there that would suggest that it's not working,
and I've got a 600x here that works fine.
Comment 11 CJeness 2001-01-15 12:43:56 EST
What suggests to me that it is not working is that I do not here anything.  This
happens to be a dual boot computer -- OS/2 and Linux.  Under OS/2, the sound
works fine.  Can you post your modules.conf?  Did you do anything special to get
sound working?
Comment 12 Bill Nottingham 2001-01-15 12:49:04 EST
I don't deny that it doesn't work for you, there's just nothing in
the logs that indicate something failed.

My modules.conf is dead simple:

alias sound-slot-0 cs46xx

No options needed.

How are you testing the sound?

Comment 13 CJeness 2001-01-15 13:51:58 EST
I am testing the sound by attempting to play a CD using the Gnome CD player
which displays automatically when I insert the CD.  This is the same technique
that I have used to test the sound on my 1472i ThinkPad where sound does work
correctly for the first time.  On the 600x, the CD appears to play based on the
elapsed time display; however, I do not here anything even when I turn the
volume up as loud as possible.
Comment 14 Alan Cox 2003-06-10 14:23:32 EDT
Closing. The problem turned out to be that the CS46XX on the TP600X is used as
an auxilliary sound device and the system sound device is the CS423x as with
other thinkpads of that era.

sndconfig told to not probe PCI devices should do the right thing
Comment 15 Bill Nottingham 2003-06-10 14:32:03 EDT
The sound on the 600*X* is native. I have one.
The 600 or 600E might use cs42xx.
Comment 16 Bugzilla owner 2004-09-30 11:38:52 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.