Bug 221751 - HVM guest does not start anymore (dma_timer_expiry)
HVM guest does not start anymore (dma_timer_expiry)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Steven Rostedt
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-07 07:25 EST by Felix Schwarz
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-07 08:37:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Felix Schwarz 2007-01-07 07:25:27 EST
Description of problem:
I'm using Xen on a FC6 (x86_64) system (Dell E521, AMD X2 4200 with
Pacifica-Support) with a number of different guest systems (paravirtualized as
well as fully virtualized ones). One of these is a FC6 (i386), running in HVM
mode (because AFAIK x86_64 Xen does not support i386 paravirtualized guests).
Everything worked fine so far. Today, I did a yum update in the guest machine,
loading the updates for the last 2-3 weeks. This was okay to. Unfortunately, the
guest won't start anymore.

I'm getting these boot messages (manually typed in here, typing errors may be
present):
...
no fstab.sys, mounting internal defaults
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
... wait for some time ...
hda: DMA interrupt recovery
hda: lost interrupt
hda: dma_timer_expiry: dma status == 0x24
(again and again)

My host system is fully patched as as of 01/06/2007 and so is the guest system.
As a special exception, I am running kernel version
2.6.18-1.2857.4.2.fc6.0.2.sctxen on the host system in order to get my Broadcom
network chipset working. 

I can boot the guest just fine using qemu from Fedora Extras.

How reproducible:
Always (host system reboot did not solved the problem).
Comment 1 Felix Schwarz 2007-01-07 16:19:20 EST
I was able to gather some more info after creating another HVM FC6 guest (32
bit) which did not start either after loading all the updates. Again, this was a
minimal install of Fedora (no X). In the second machine, the error message had
something to do with not finding any LVM volumes which is bad because I used the
proposed standard partitioning so the system could not find my /.

However, the system booted with the old kernel (2.6.18-1.2798.fc6 instead of
2.6.18-1.2869.fc6). Therefore I tried booting with my first VM with the same
kernel version and it works. Obviously, something in the kernel package changed
which broke my HVM guests... I do not experience these problems with my normal
FC6 machines (i386 and x86_64) which also use LVM partitioning.
Comment 3 Felix Schwarz 2007-07-07 08:37:06 EDT
works for me now.

Note You need to log in before you can comment on or make changes to this bug.