Bug 22176 - Detection of more than 8 LUNS broke between 2.2.16-4 and 2.2.16-22
Summary: Detection of more than 8 LUNS broke between 2.2.16-4 and 2.2.16-22
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 23357 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-12 19:06 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-13 20:44:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The qlogic changes I made to the 2.2.16-4 kernel(README inside) (209.25 KB, application/octet-stream)
2000-12-12 19:07 UTC, Need Real Name
no flags Details
dmesg and /proc/scsi/scsi for the 2.2.16-4 kernel that works (1.87 KB, application/octet-stream)
2000-12-12 19:09 UTC, Need Real Name
no flags Details
dmesg and /proc/scsi/scsi from the standard 2.2.16-22 kernel that doesnt work (2.08 KB, application/octet-stream)
2000-12-12 19:10 UTC, Need Real Name
no flags Details

Description Need Real Name 2000-12-12 19:06:38 UTC
Between RedHat kernels version 2.2.16-4 and 2.2.16-22, the detection of 
more than 8 LUNS automatically has broke. We must use 
echo "scsi add-single-device 4 0 0 8" > /prov/scsi/scsi
to get the additional LUNS detected.

We use the Qlogic driver from Qlogic named qla2x00. For the 2.2.16-4 
kernel, I patched the SRC RPM, which I have included in the qla-2.2.16-
4.tar.gz file(README inside). For the 2.2.16-22 kernel, the qla2x00 driver 
has now been included in the stock kernel, so no modification has been 
made.

These are smp compiled kernels for i686

Inside the 2.2.16-4-custom.tar.gz, you can see that the disks are detected 
properly in the dmesg. Specifically on scsi bus 4 and 6, Lun 8 is detected.

Inside the 2.2.16-22.tar.gz, dmesg shows that on scsi bus 6 and 8, the 
kernel detects up to 7 and stops.  The add-single-device.dmesg file shows 
the additional luns that get detected after a 
add-single-device [46] 0 0 8
The add-single-device.scsi shows the result of /proc/scsi/scsi after the 
add.

I have included the contents of lilo.conf and modules.conf below 


lilo.conf
boot=/dev/sda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
linear
image=/boot/vmlinuz-2.2.16-4smp
	label=linux-bug-cust
	initrd=/boot/initrd-2.2.16-4smp.img
	read-only
	root=/dev/sda9
	append="reboot=warm max_scsi_luns=128"
image=/boot/vmlinuz-2.2.16-22smp
	label=linux-bug-stok
	initrd=/boot/initrd-2.2.16-22smp.img
	read-only
	root=/dev/sda9
	append="reboot=warm max_scsi_luns=128"

modules.conf
alias eth0 eepro100
alias eth1 eepro100
alias scsi_hostadapter megaraid
alias scsi_hostadapter1 ncr53c8xx
alias parport_lowlevel parport_pc
alias scsi_hostadapter2 ncr53c8xx
alias scsi_hostadapter3 ncr53c8xx
alias scsi_hostadapter3 qla2x00
alias scsi_hostadapter4 qla2x00
alias scsi_hostadapter5 qla2x00
alias scsi_hostadapter6 qla2x00

Comment 1 Need Real Name 2000-12-12 19:07:55 UTC
Created attachment 6312 [details]
The qlogic changes I made to the 2.2.16-4 kernel(README inside)

Comment 2 Need Real Name 2000-12-12 19:09:15 UTC
Created attachment 6313 [details]
dmesg and /proc/scsi/scsi for the 2.2.16-4 kernel that works

Comment 3 Need Real Name 2000-12-12 19:10:06 UTC
Created attachment 6314 [details]
dmesg and /proc/scsi/scsi from the standard 2.2.16-22 kernel that doesnt work

Comment 4 Need Real Name 2000-12-12 19:16:40 UTC
i686 is correct. I picked ia64 as the platform by mistake

Comment 5 Need Real Name 2001-01-27 21:41:02 UTC
This is the same problem as bug 23357

Comment 6 Matt Domsch 2001-03-13 20:44:37 UTC
*** Bug 23357 has been marked as a duplicate of this bug. ***

Comment 7 Matt Domsch 2001-07-20 16:21:26 UTC
Resolved in later errata kernels, and certainly resolved in the 7.1 release.
Closing.


Note You need to log in before you can comment on or make changes to this bug.