Bug 221821 - Can't use scim
Can't use scim
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Jens Petersen
Depends On:
  Show dependency treegraph
Reported: 2007-01-08 05:50 EST by Andreas Tunek
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-01-23 18:54:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Screenshot of the two scim-launchers (18.56 KB, image/png)
2007-01-08 07:51 EST, Andreas Tunek
no flags Details
Screenshot of im-chooser (57.94 KB, image/png)
2007-01-10 05:54 EST, Andreas Tunek
no flags Details

  None (edit)
Description Andreas Tunek 2007-01-08 05:50:21 EST
Description of problem: When I press ctrl-space or left-click on the
scim/keyboard icon nothing happens and I can not choose another input method. I
can right-click on the scim/keyboard icon and set up everything, but nothing
happens when I left-click.

Version-Release number of selected component (if applicable):
scim.i386                                1.4.4-37.fc6           installed       
scim-anthy.i386                          1.2.2-1.fc6            installed       
scim-bridge.i386                         0.4.7-1.fc6            installed       
scim-bridge-gtk.i386                     0.4.7-1.fc6            installed       

How reproducible:

Steps to Reproduce:
1. Right-click on scim/keyboard icon. Something happens.
2. Left-click on scim/keyboard icon or do ctrl-space. Nothing happens.
3. Profit?
Actual results:
See above

Expected results:
See above

Additional info:
Could be a configuration problem, but I have not changed anything and it worked
good before. Maybe it is the latest' updates fault?
Comment 1 Andreas Tunek 2007-01-08 07:51:45 EST
Created attachment 145050 [details]
Screenshot of the two scim-launchers
Comment 2 Jens Petersen 2007-01-08 18:27:33 EST
How about in an xterm say?

What is your version of gtk2?
Comment 3 Andreas Tunek 2007-01-09 04:30:46 EST
from yum:

gtk2.i386  2.10.4-10.fc6          installed  

I also saw that I had an older version of gtk2 installed, but I removed that.
SCIM still does not work. 

I also still have to scim launchers (as in the screenshot).
Comment 4 Andreas Tunek 2007-01-09 04:34:25 EST
Can not use SCIM in xterm either.....
Comment 5 Jens Petersen 2007-01-09 18:58:29 EST
Okay thanks, if you (install and) run im-chooser, does it say SCIM is configured?

Do any of these work:
$ GTK_IM_MODULE=scim gedit
$ GTK_IM_MODULE=scim-bridge gedit

Or how about if you run "scim-restart"?
Comment 6 Andreas Tunek 2007-01-10 05:49:42 EST
Does not work when I do scim restart, but this is the output:
[tuna@localhost ~]$ scim-restart 
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
GTK Panel of SCIM 1.4.4

Starting SCIM as daemon ...
Comment 7 Andreas Tunek 2007-01-10 05:54:17 EST
Created attachment 145245 [details]
Screenshot of im-chooser
Comment 8 Andreas Tunek 2007-01-10 05:56:11 EST
"Do any of these work:
$ GTK_IM_MODULE=scim gedit
$ GTK_IM_MODULE=scim-bridge gedit"

Neither works, can not change the imput method in gedit.
Comment 9 Andreas Tunek 2007-01-23 08:52:12 EST
It would seem that the scim update took care of all my problems, so now I type
using scim again. Thanks for all your help anyway.

Note You need to log in before you can comment on or make changes to this bug.