This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 221829 - "cpuspeed" start-up script aborts because of syntex error
"cpuspeed" start-up script aborts because of syntex error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cpuspeed (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-08 07:53 EST by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-08 10:58:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2007-01-08 07:53:29 EST
Description of problem:
The "cpuspeed" start-up script aborts upon execution due to a
syntax error:

  "Starting cpuspeed: ./cpuspeed: line 75: let: UP_THRESHOLD=100-: syntax \
     error: operand expected (error token is "-")
  ./cpuspeed: line 80: let: DOWN_THRESHOLD=100-: syntax error: operand \
     expected (error token is "-")"

Version-Release number of selected component (if applicable):
cpuspeed-1.2.1-1.47.fc7

How reproducible:
Always

Steps to Reproduce:
1. Boot current "rawhide"
2. Watch "cpuspeed" start-up message.
  
Actual results:
"cpuspeed" fails to launch.

Expected results:
"cpuspeed" launches and takes control of the cpu speed.

Additional info:
The next output line indicates a further problem which maybe triggered
by the former:

  "Error: The '-p' option must be followed by 2 integers"
Comment 1 Jarod Wilson 2007-01-08 10:58:39 EST
Whoops, I accidentally got the if/else conditions backwards in that build...
I've pushed a corrected version through the build system, should show up on
mirrors in due time...

Note You need to log in before you can comment on or make changes to this bug.