Bug 22186 - ssh-add -l shows filenames instead of comments for DSA keys.
Summary: ssh-add -l shows filenames instead of comments for DSA keys.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh   
(Show other bugs)
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-12 22:51 UTC by David Woodhouse
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 12:43:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Woodhouse 2000-12-12 22:51:19 UTC
e.g.:

1024 db:5a:9c:fd:11:25:23:c0:37:c8:19:d3:97 dwmw2@dwmw2.baythorne.internal
1024 78:24:04:95:40:b2:80:9b:94:d5:56:19:65 dwmw2@passion.cygnus
1024 4e:bd:62:75:62:df:26:34:6b:a5:12:9a:82 /home/dwmw2/.ssh/id_dsa
1024 e4:01:5c:f3:6f:de:c6:b4:2d:b2:72:fd:be /home/dwmw2/.ssh/id_dsa

Of course, it's fairly simple to guess in this case which the two DSA keys
are - they're the matching pair for the properly-identified RSA keys. But
it's not ideal.

Comment 1 David Woodhouse 2001-01-16 09:42:41 UTC
On further investigation, I'm not convinced that the DSA keys actually _have_
comments. Whether this is because the DSA keys _can't_ have comments, or whether
ssh-keygen -d just doesn't add them by default, I don't know.

Comment 2 Damien Miller 2003-02-10 03:41:02 UTC
You are correct. SSH protocol v.2 keys (RSA and DSA) do not have comments which
are sent over the wire like SSH v.1 keys.

Comment 3 Tomas Mraz 2005-02-04 12:43:32 UTC
Seems to be a feature.



Note You need to log in before you can comment on or make changes to this bug.