Bug 221868 - Incorrect invocation option breaks CVS groff
Incorrect invocation option breaks CVS groff
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-08 11:54 EST by Eric Raymond
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-09 04:59:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Raymond 2007-01-08 11:54:35 EST
Description of problem:
Installing groff from CVS on FC6 breaks man.
The problem is a bogus "--legacy NROFF_OLD_CHARSET" option in /etc/man.config.

Version-Release number of selected component (if applicable):
groff 1.19-pre development tree
man 1.6d

How reproducible:
Always.

Steps to Reproduce:
1. Attempt to brose any manual page
  
Actual results:
Blank page.

Expected results:
Screenful of text

Additional info:
Changing /etc/man.config to declare

NROFF		/usr/bin/nroff -c -mandoc 2>/dev/null

fixes the problem.
Comment 1 Ivana Varekova 2007-01-09 04:59:56 EST
Thank you for your bug report.
This problem is fixed in man-1.6e-2.fc7 and man-1.6d-2.fc6.

Note You need to log in before you can comment on or make changes to this bug.