Bug 221916 - yum for RHN and system-cdinstall-helper fails when pulling from RHN: Missing key: RPM-GPG-KEY-beta
yum for RHN and system-cdinstall-helper fails when pulling from RHN: Missing ...
Status: CLOSED NOTABUG
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels (Show other bugs)
rhn415
All Linux
medium Severity high
: ---
: ---
Assigned To: Bret McMillan
:
Depends On:
Blocks: SGI_Blocker_5.0.0
  Show dependency treegraph
 
Reported: 2007-01-08 17:16 EST by Erik Jacobson
Modified: 2007-04-18 13:56 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-22 15:59:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Jacobson 2007-01-08 17:16:30 EST
This was observed in RHEL5 RC Snapshot5.

We were using the system-cdinstall-helper to install our add-on product.
A dependency from RHEL5 needed to be take in -- sysstat.

When it tried to use RHN to take this package in, it failed with the following
error:

GPG key retrieval failed: [Errno 5] OSError: [Errno 2] No such file or
directory: '/etc/pki/rpm-gpg/RPM-GPG-KEY-beta'

A work-around that worked for me was to
cd /etc/pki/rpm-gpg
cp RPM-GPG-KEY-redhat-beta RPM-GPG-KEY-beta

then try again.  I was then able to import the needed key and continue on.

We're filing this out of an abundance of caution.  I realize the error key
says beta, but we also need to test installation and this late stage and
we didn't want a problem to go unreported and cause trouble at release.

My guess is you're in the process of changing key names around and snapshot5
doesn't match RHN or something to that affect.
Comment 1 Erik Jacobson 2007-01-08 17:27:28 EST
I just repeated this issue on x86_64 as well - so it affects ia64 and
x86_64 so far.
Comment 2 James Bowes 2007-01-10 13:01:58 EST
This is an issue with some of the gpg_key field for the beta channels. Either we
have to replace the old location with the new one, or append the new location to
the list (space separated).
Comment 3 Erik Jacobson 2007-01-17 23:48:16 EST
Will this be fixed by the time rhel5 releases?  This will impact our customers
trying to install our software on rhel5.  We'll need to document ugly
work-arounds and/or create wrapper scripts to work around this otherwise.
Comment 4 Erik Jacobson 2007-01-18 10:52:31 EST
This is still in rhel5 rc snapshot7.

If I were Red Hat, I would have this bug flagged at a very high priority.
This even fails trying to use yum to install a package from RHN - with no
special SGI packages or anything.

I wanted to add the netconfig package and I can't:

[root@minime1 ~]# yum install netconfig
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Setting up Install Process
Setting up repositories
rhel-ia64-server-5-beta   100% |=========================|  950 B    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 598 kB    00:01
################################################## 2045/2045
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for netconfig to pack into transaction set.
netconfig-0.8.24-1.2.2.1. 100% |=========================|  14 kB    00:00
---> Package netconfig.ia64 0:0.8.24-1.2.2.1 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 netconfig               ia64       0.8.24-1.2.2.1   rhel-ia64-server-5-beta   88 k

Transaction Summary
=============================================================================
Install      1 Package(s)
Update       0 Package(s)
Remove       0 Package(s)

Total download size: 88 k
Is this ok [y/N]: y
Downloading Packages:
(1/1): netconfig-0.8.24-1 100% |=========================|  88 kB    00:00
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 897da07a


GPG key retrieval failed: [Errno 5] OSError: [Errno 2] No such file or
directory: '/etc/pki/rpm-gpg/RPM-GPG-KEY-beta'
Comment 8 Bret McMillan 2007-02-22 15:59:03 EST
For RHEL5 GA, the gpg file that will be used/tied to the RHN Channel is called:

/etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release

in my testing against our QA environments, the key tied to the GA channel is:

file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release

so it should be fine for GA.  The error the user was seeing is he was
registering snapshot 5 rc to the 4.92/beta2 era channels, and the location of
the gpg key changed.

Note You need to log in before you can comment on or make changes to this bug.