Bug 221943 - anaconda bails out with "TypeError: list objects are unhashable" on an attempt to upgrade
anaconda bails out with "TypeError: list objects are unhashable" on an attemp...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-08 22:49 EST by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-06 16:29:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash information as dumped by anaconda (46.67 KB, text/plain)
2007-01-08 22:49 EST, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2007-01-08 22:49:23 EST
Description of problem:

I tried to update to FC6 a small "internal" server which so far
was happy with RHL 7.2.  All attempts ended up with an error like
the one quoted in summary.  This was happening while anaconda was
trying to inventory packages to install.

Full anacdump.txt dumped by anaconda attached.

Version-Release number of selected component (if applicable):
anaconda like provided on FC6 installation images

How reproducible:
always
Comment 1 Michal Jaegermann 2007-01-08 22:49:23 EST
Created attachment 145137 [details]
crash information as dumped by anaconda
Comment 2 David Cantrell 2007-01-09 08:50:27 EST
Were you trying to upgrade a RHL 7.2 system to FC-6?  If so, that's not
supported.  We can only guarantee previous Fedora releases upgradeable to the
current one.  So, FC-5 to FC-6 works.  RHL 7.2 to FC-6 definitely won't work.
Comment 3 Michal Jaegermann 2007-01-09 12:22:05 EST
> Were you trying to upgrade a RHL 7.2 system to FC-6?
Yes, like I said.
> If so, that's not supported.
Supported or not supported but Python errors from anaconda seems
like not something what should happen.
> We can only guarantee previous Fedora releases upgradeable 
> to the current one.
This is _far_ too little in the real life.  Besides in the past
there were really no problems with skipping few releases.
Granted, what I tried was somewhat extreme but in any case
one would think that anaconda runs in an evironment of an
installation image so why it should care about a status of
its target?
Comment 4 David Cantrell 2007-01-09 15:11:40 EST
You're right, most people don't install each new release.  Some effort is made
to see if upgrades work from 2 releases back, but there are so many other
factors that go in to it.  Sometimes it's impossible to do a smooth upgrade.

Anaconda cares about the target system because it needs to know the possible set
of packages there and account for obsoletes and entirely new packages.  That
happens a lot.

We can probably do a better job of telling the user that upgrading their very
old installation to this release won't work, rather than dumping the traceback.
Comment 5 David Cantrell 2007-03-06 16:29:30 EST
Closing this as WONTFIX because we cannot keep knowledge of past releases in
anaconda forever.  FC releases change a lot from release to release and that's
hard enough to guarantee upgrades.

Note You need to log in before you can comment on or make changes to this bug.