Bug 222093 - new traceroute breaks scripts
new traceroute breaks scripts
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: traceroute (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Bacovsky
:
Depends On: 221764
Blocks: 223784
  Show dependency treegraph
 
Reported: 2007-01-10 04:14 EST by Martin Bacovsky
Modified: 2013-04-12 14:59 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2007-1103
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-12 10:49:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Bacovsky 2007-01-10 04:14:42 EST
+++ This bug was initially created as a clone of Bug #221764 +++

Newer versions of traceroute fail when passed args like:

   traceroute -w2 1.2.3.4

Note the lack of space between the -w and 2.  This new restriction breaks
existing scripts that have worked fine for a decade.

-- Additional comment from dmitry@butskoy.name on 2007-01-09 07:58 EST --
Thanks for report!

Try new upstream version at:
http://dmitry.butskoy.name/traceroute/traceroute-2.0.3.tar.gz

(You can rebuild it locally using "rpmbuild -ta traceroute-2.0.3.tar.gz",
if you don't want to wait for an official update ;) )


> This new restriction breaks existing scripts that have worked fine for a
> decade.

Benjamin,
Whether those scripts are some wide-spread code, or it was written just locally?
Comment 1 Martin Bacovsky 2007-01-10 04:25:30 EST
I think this should be included in RHEL-5 too. I would prefere to upgrade to
upstream traceroute-2.0.3. If it is not possible I can create patch.

Changes since previous release:
>       *  version 2.0.3
>
>       *  allow option args without separator (add CLIF_MAY_JOIN_ARG flag),
>          for compatibility (Benjamin LaHaise)
>
>       *  no more "tcptraceroute" symlink for rpm packages, because
>          it conflicts with the same-name old package anyway (James Ralston)
>
>       *  fix compilation on glibc < 2.4 (Andy Shevchenko)
Comment 2 RHEL Product and Program Management 2007-01-10 04:40:36 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 9 Martin Bacovsky 2007-11-29 06:06:52 EST
This issue should be fixed in traceroute-2.0.1-3.el5.
Comment 13 errata-xmlrpc 2007-12-12 10:49:49 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-1103.html

Note You need to log in before you can comment on or make changes to this bug.