Bug 22220 - cannot install with VIA Cyrix III
cannot install with VIA Cyrix III
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-13 08:28 EST by Brad Ferguson
Modified: 2013-01-10 16:36 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-29 17:49:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Ferguson 2000-12-13 08:28:38 EST
I've found a couple of problems with RH Linux 7.0 on the VIA Cyrix III 
processor.

Here's the summary:
LILO problem: The install seems to run fine, but at the end, LILO can't 
open /dev/hda, and doesn't write MBR. Also will not write a boot floppy.
	
Boot problem: boot process stops after loading kernel, before starting 
init. Last message is "Freeing unused kernel memory"

I've narrowed this down by experimentation, and it looks like the most 
likely cause of these problems is that the installer picks a LILO binary 
and a kernel based on the Family of the CPU. Family 6 results in binaries 
that contain CMOV or other P6 specific code, probably because of "i686" 
compiler optimizations. The VIA Cyrix III processor does not support CMOV, 
and several other "optional" features. The presence of these features can 
be detected by reading the CPU Feature Flags through CPUID.

More information about the Cyrix III processor can be found at:
http://www.viatech.com/products/cyr3.htm

Thank you,
Brad Ferguson
Centaur Technology
brad@centtech.com
Comment 1 Michael Fulbright 2000-12-13 14:56:18 EST
Assigned to a developer - thank you for the information.
Comment 2 Mark Snell 2001-02-01 22:28:45 EST
I had this problem also, during a writeup for PC Magazine Australia. A little more digging into the /tmp/install.log shows that glibc was not installed, and 
about 3/4 of the packages after it were not installed either (probably due to dependancies on glibc).

I love to see a resolution to this to print in a later addition of the magazine.

Mark Snell
RMIT IT Test Lab
mark.snell@rmit.edu.au
Comment 3 Brock Organ 2001-03-26 15:10:52 EST
this behavior is confirmed for 7.0 & internal post-wolverine versions of Red Hat
Linux ...

Comment 4 Brock Organ 2001-03-26 17:25:47 EST
The problem is the cpu family indicates 6 (or Pentium II), but this machine does
not have the "cmov" instruction that is present in other Pentium II instruction
sets; So when the i686 package (such as glibc) is installed, it contains
"illegal instructions" that cause the package to be unusable ...

[root@test152 /root]# cat /proc/cpuinfo
processor       : 0
vendor_id       : CentaurHauls
cpu family      : 6
model           : 6
model name      : VIA Samuel
stepping        : 2
cpu MHz         : 601.388
cache size      : 128 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu de tsc msr mce cx8 mtrr pge mmx 3dnow
bogomips        : 1199.30

Here is a sample PII with the cmov instruction (see the flags field):

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 5
model name      : Pentium II (Deschutes)
stepping        : 3
cpu MHz         : 400.911
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat
pse36 mmx
fxsr
bogomips        : 799.53
Comment 5 Brock Organ 2001-03-26 17:27:11 EST
of course, this is just restating what mark said above (and said much better :)
)
Comment 6 Brock Organ 2001-03-26 17:42:00 EST
I mean, what brad said above ... :)
Comment 7 Glen Foster 2001-03-29 17:49:34 EST
Tested in yesterday's and today's trees with successes.  It appears this has
been fixed.
Comment 8 Brock Organ 2001-04-02 09:15:49 EDT
verified fixed in qa0329.0, qa0330.0, qa0401.0 using the above 600 Mhz Via 
Samuel ...

Note You need to log in before you can comment on or make changes to this bug.