Bug 222205 - gnome-terminal ends up with immediate SIGSEGV after latest updates
Summary: gnome-terminal ends up with immediate SIGSEGV after latest updates
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vte   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-10 21:33 UTC by Michal Jaegermann
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-24 16:03:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bugs buddy information from a gnome-terminal crash (8.34 KB, text/plain)
2007-01-10 21:33 UTC, Michal Jaegermann
no flags Details

Description Michal Jaegermann 2007-01-10 21:33:41 UTC
Description of problem:

With a series of updates from 20070110 set gnome-terminal immediately
crashes on an attempt to start.  Luckily things like rxvt or xterm still
work.  A run under gdb produces the following backtrace:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 46912535475664 (LWP 6135)]
0x00002aaa00000000 in ?? ()
(gdb) where
#0  0x00002aaa00000000 in ?? ()
#1  0x00002aaaaade36b0 in g_cclosure_marshal_VOID__OBJECT ()
   from /usr/lib64/libvte.so.9
#2  0x00007fff78c58360 in ?? ()
#3  0x00002aaaaade36ac in g_cclosure_marshal_VOID__OBJECT ()
   from /usr/lib64/libvte.so.9
#4  0x00000000008aeac0 in ?? ()
#5  0x0000000000000039 in ?? ()
#6  0x00002aaaaaafe5fb in vte_terminal_accessible_new ()
   from /usr/lib64/libvte.so.9
#7  0x00002aaaaaad6e8d in _vte_debug_parse_string ()
   from /usr/lib64/libvte.so.9
#8  0x00002aaaaaae3b9e in vte_terminal_set_emulation ()
   from /usr/lib64/libvte.so.9
#9  0x00002aaaaaae9ffa in vte_terminal_feed_child ()
   from /usr/lib64/libvte.so.9
#10 0x000000325e429ad0 in g_type_create_instance ()
   from /lib64/libgobject-2.0.so.0
#11 0x000000325e41176d in g_object_set () from /lib64/libgobject-2.0.so.0
#12 0x000000325e40f5c4 in g_object_newv () from /lib64/libgobject-2.0.so.0
#13 0x000000325e40ffec in g_object_new_valist ()
   from /lib64/libgobject-2.0.so.0
#14 0x000000325e410221 in g_object_new () from /lib64/libgobject-2.0.so.0
#15 0x00002aaaaaae472a in vte_terminal_new () from /usr/lib64/libvte.so.9
#16 0x0000000000427dac in g_cclosure_marshal_VOID__OBJECT ()
#17 0x0000000000424fdc in g_cclosure_marshal_VOID__OBJECT ()
#18 0x000000325e429ad0 in g_type_create_instance ()
   from /lib64/libgobject-2.0.so.0
#19 0x000000325e41176d in g_object_set () from /lib64/libgobject-2.0.so.0
#20 0x000000325e40f5c4 in g_object_newv () from /lib64/libgobject-2.0.so.0
#21 0x000000325e40ffec in g_object_new_valist ()
   from /lib64/libgobject-2.0.so.0
#22 0x000000325e410221 in g_object_new () from /lib64/libgobject-2.0.so.0
#23 0x0000000000417f0c in g_cclosure_marshal_VOID__OBJECT ()
#24 0x00000000004189eb in g_cclosure_marshal_VOID__OBJECT ()
#25 0x0000000000419565 in g_cclosure_marshal_VOID__OBJECT ()
#26 0x000000366061d924 in __libc_start_main () from /lib64/libc.so.6
#27 0x000000000040f569 in g_cclosure_marshal_VOID__OBJECT ()
#28 0x00007fff78c59238 in ?? ()
#29 0x0000000000000000 in ?? ()
(gdb)

A crash kicks bugs-buddy into an action which drops a core too
but still has something to say.  An output from bugs-buddy is attached.

I have no idea if this is limited to x86_64 or not.

Version-Release number of selected component (if applicable):
gnome-terminal-2.16.1-1.fc7

How reproducible:
always

Comment 1 Michal Jaegermann 2007-01-10 21:33:42 UTC
Created attachment 145286 [details]
bugs buddy information from a gnome-terminal crash

Comment 2 Jeremy Katz 2007-01-10 22:24:02 UTC
Should be fixed with vte-0.15.1-2

Comment 3 Horst H. von Brand 2007-01-10 22:38:46 UTC
Doesn't crash on i386.

Comment 4 Paul Dickson 2007-03-03 07:09:00 UTC
I've seen the gome-terminal crash in i386 on initial session startup and when I
create a new tab.

grip also crashes because of vte.

Comment 5 Paul Dickson 2007-03-03 07:14:59 UTC
Oh! this is an old bug, not the newer vte-0.15.5-1.fc7.i386.rpm which is cause
me trouble.  My other system (running yum) says there's an even newer version
this evening.

Comment 6 Matthias Clasen 2007-04-24 04:39:09 UTC
Paul, are you still seeing this problem ?

Comment 7 Paul Dickson 2007-04-24 06:20:13 UTC
No.  I'm no longer seeing this problem.

Comment 8 Matthias Clasen 2007-04-24 16:03:37 UTC
Thanks, I'll close this then.


Note You need to log in before you can comment on or make changes to this bug.