Bug 222290 - the package "lirc" cannot be upgraded via yum, pup etc.
the package "lirc" cannot be upgraded via yum, pup etc.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lirc (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
http://img223.imageshack.us/img223/78...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-11 09:34 EST by Philipp N.
Modified: 2014-01-21 17:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-17 15:39:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philipp N. 2007-01-11 09:34:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); de; rv:1.8.0.9) Gecko/20061219 Fedora/1.5.0.9-1.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
The package lirc cannot be upgraded. Removing and reinstalliing of the package is also impossible, because it has some important dependencies.
I both tried pup and yum!

The same error-message...

Version-Release number of selected component (if applicable):
 lirc-0.8.1-1.fc6 and lirc-0.8.1-0.2.pre2.fc6

How reproducible:
Always


Steps to Reproduce:
type "yum update" into the root-terminal or just start pup

Actual Results:
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package glibc.i686 0:2.5-10.fc6 set to be updated
---> Package libgomp.x86_64 0:4.1.1-51.fc6 set to be updated
---> Package wget.x86_64 0:1.10.2-8.fc6.1 set to be updated
---> Package nscd.x86_64 0:2.5-10.fc6 set to be updated
---> Package libgcj.i386 0:4.1.1-51.fc6 set to be updated
---> Package glibc-headers.x86_64 0:2.5-10.fc6 set to be updated
---> Package lirc.x86_64 0:0.8.1-1.fc6 set to be updated
---> Package glibc-devel.x86_64 0:2.5-10.fc6 set to be updated
---> Package cpuspeed.x86_64 1:1.2.1-1.43.fc6 set to be updated
---> Package libgcj.x86_64 0:4.1.1-51.fc6 set to be updated
---> Package libgcc.x86_64 0:4.1.1-51.fc6 set to be updated
---> Package libstdc++.i386 0:4.1.1-51.fc6 set to be updated
---> Package autofs.x86_64 1:5.0.1-0.rc3.2 set to be updated
---> Package libstdc++.x86_64 0:4.1.1-51.fc6 set to be updated
---> Package gcc.x86_64 0:4.1.1-51.fc6 set to be updated
---> Package libgcc.i386 0:4.1.1-51.fc6 set to be updated
---> Package glibc.x86_64 0:2.5-10.fc6 set to be updated
---> Package glibc-common.x86_64 0:2.5-10.fc6 set to be updated
---> Package cpp.x86_64 0:4.1.1-51.fc6 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 autofs                  x86_64     1:5.0.1-0.rc3.2  updates           801 k
 cpp                     x86_64     4.1.1-51.fc6     updates           2.9 M
 cpuspeed                x86_64     1:1.2.1-1.43.fc6  updates            29 k
 gcc                     x86_64     4.1.1-51.fc6     updates           5.0 M
 glibc                   i686       2.5-10.fc6       updates           5.1 M
 glibc                   x86_64     2.5-10.fc6       updates           4.7 M
 glibc-common            x86_64     2.5-10.fc6       updates            16 M
 glibc-devel             x86_64     2.5-10.fc6       updates           2.4 M
 glibc-headers           x86_64     2.5-10.fc6       updates           595 k
 libgcc                  x86_64     4.1.1-51.fc6     updates            84 k
 libgcc                  i386       4.1.1-51.fc6     updates            81 k
 libgcj                  i386       4.1.1-51.fc6     updates            17 M
 libgcj                  x86_64     4.1.1-51.fc6     updates            18 M
 libgomp                 x86_64     4.1.1-51.fc6     updates            69 k
 libstdc++               i386       4.1.1-51.fc6     updates           349 k
 libstdc++               x86_64     4.1.1-51.fc6     updates           342 k
 lirc                    x86_64     0.8.1-1.fc6      extras            250 k
 nscd                    x86_64     2.5-10.fc6       updates           151 k
 wget                    x86_64     1.10.2-8.fc6.1   updates           582 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update      19 Package(s)         
Remove       0 Package(s)         

Total download size: 74 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test


Transaction Check Error:   file /usr/share/man/man1/ircat.1.gz from install of lirc-0.8.1-1.fc6 conflicts with file from package lirc-0.8.1-0.2.pre2.fc6
  file /usr/share/man/man1/irexec.1.gz from install of lirc-0.8.1-1.fc6 conflicts with file from package lirc-0.8.1-0.2.pre2.fc6
  file /usr/share/man/man1/irpty.1.gz from install of lirc-0.8.1-1.fc6 conflicts with file from package lirc-0.8.1-0.2.pre2.fc6
  file /usr/share/man/man1/irrecord.1.gz from install of lirc-0.8.1-1.fc6 conflicts with file from package lirc-0.8.1-0.2.pre2.fc6
  file /usr/share/man/man1/irsend.1.gz from install of lirc-0.8.1-1.fc6 conflicts with file from package lirc-0.8.1-0.2.pre2.fc6
  file /usr/share/man/man1/irw.1.gz from install of lirc-0.8.1-1.fc6 conflicts with file from package lirc-0.8.1-0.2.pre2.fc6
  file /usr/share/man/man1/irxevent.1.gz from install of lirc-0.8.1-1.fc6 conflicts with file from package lirc-0.8.1-0.2.pre2.fc6
  file /usr/share/man/man1/lircrcd.1.gz from install of lirc-0.8.1-1.fc6 conflicts with file from package lirc-0.8.1-0.2.pre2.fc6
  file /usr/share/man/man1/mode2.1.gz from install of lirc-0.8.1-1.fc6 conflicts with file from package lirc-0.8.1-0.2.pre2.fc6
  file /usr/share/man/man1/xmode2.1.gz from install of lirc-0.8.1-1.fc6 conflicts with file from package lirc-0.8.1-0.2.pre2.fc6
  file /usr/share/man/man8/lircd.8.gz from install of lirc-0.8.1-1.fc6 conflicts with file from package lirc-0.8.1-0.2.pre2.fc6
  file /usr/share/man/man8/lircmd.8.gz from install of lirc-0.8.1-1.fc6 conflicts with file from package lirc-0.8.1-0.2.pre2.fc6



Expected Results:
No Error message and an upgraded lirc-package...

Additional info:
my lirc depends on:
=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Removing:
 lirc                    i386       0.8.1-0.2.pre2.fc6  installed         586 k
 lirc                    x86_64     0.8.1-0.2.pre2.fc6  installed         597 k
Removing for dependencies:
 audacious               x86_64     1.2.2-2.fc6      installed         2.6 M
 audacious-plugins       x86_64     1.2.5-2.fc6      installed         3.5 M
 audacious-plugins-nonfree-aac  x86_64     1.2.5-1.lvn6     installed         323 k
 audacious-plugins-nonfree-mp3  x86_64     1.2.5-1.lvn6     installed         188 k
 audacious-plugins-nonfree-wma  x86_64     1.2.5-1.lvn6     installed         132 k
 mencoder                x86_64     1.0-0.66.rc1.lvn6  installed         2.8 M
 mplayer                 i386       1.0-0.66.rc1.lvn6  installed         5.0 M
 mplayer                 x86_64     1.0-0.66.rc1.lvn6  installed         5.0 M
 mplayer-fonts           noarch     1.1-4.lvn6       installed         5.1 M
 mplayerplug-in          i386       3.35-1.lvn6      installed         1.5 M
 mplayerplug-in          x86_64     3.35-1.lvn6      installed         1.5 M
 totem-xine              x86_64     2.16.2-2.lvn6    installed         4.9 M
Comment 1 Jeremy Katz 2007-01-11 10:25:20 EST
You have both the i386 and x86_64 versions installed, but it looks like only the
x86_64 version is being published now
Comment 2 Philipp N. 2007-01-11 12:54:46 EST
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/6/x86_64/
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/6/i386/

I'm not sure, but I cannot find both arch's packages...

After a "yum clean all", I tried to upgrade again, but there is still this
error... and only the x86_64-package...
Comment 3 Ville Skyttä 2007-01-17 15:39:36 EST
You're looking in the wrong place, lirc is in Fedora Extras, not Core updates. 
lirc-0.8.1-1.fc6 is available in both:

http://download.fedora.redhat.com/pub/fedora/linux/extras/6/i386/
http://download.fedora.redhat.com/pub/fedora/linux/extras/6/x86_64/

Make sure that you have both i386 and x86_64 Extras repositories enabled.  But
be aware that it might not result in a sane configuration, one can't parallel
install i386 and x86_64 of all packages cleanly currently.  Unless you require
the i386 version of lirc and dependent packages, I'd suggest removing them
instead of enabling the Extras i386 repo, ie. something like "rpm -e lirc.i386
mplayer.i386 mplayerplug-in.i386"
Comment 4 Philipp N. 2007-01-18 07:39:58 EST
With an additional i386-repo it works! (Removing the i386-packages were no
solution, cause of firefox.i386, which is needed by flash (/youtube)...)

But why am I forced to use an additional i386-repo for Extras (and not for
updates and probably the other repos, too)? That doesn't make sense...
Comment 5 Ville Skyttä 2007-01-18 15:23:21 EST
Well, some of the i386 packages you've mentioned are not in the respective
x86_64 repositories so either those i386 repositories have been manually enabled
or those i386 packages been manually installed by other means.  The reason it's
not done by default in all repo configs is just that not everything in all repos
is designed/verified to be sanely parallel i386+x86_64 installable.  Manually
enabling both is not guaranteed to be free of side effects either, but good to
hear it appears to work for you.

Note You need to log in before you can comment on or make changes to this bug.