Bug 222337 - [LSPP] nash-hotplug deny is stopping ia64 from booting
[LSPP] nash-hotplug deny is stopping ia64 from booting
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-11 14:05 EST by Matt Anderson
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version: RC
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 21:15:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Anderson 2007-01-11 14:05:47 EST
Description of problem:
When installing with the mls policy an IA64 system cannot boot because it gets
continuous denies from nash-hotplug

Version-Release number of selected component (if applicable):
selinux-policy-mls-2.4.6-22.el5

How reproducible:
Everytime

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Here are the AVCs

Jan 10 17:23:42 aphex kernel: audit(1168467802.082:3): avc:  denied  { write }
for  pid=353 comm="nash-hotplug" name="zero" dev=tmpfs ino=715
scontext=system_u:system_r:kernel_t:s15:c0.c1023
tcontext=system_u:object_r:tmpfs_t:s15:c0.c1023 tclass=chr_file
Jan 10 17:23:42 aphex kernel: audit(1168467802.084:4): avc:  denied  { write }
for  pid=353 comm="nash-hotplug" name="zero" dev=tmpfs ino=715
scontext=system_u:system_r:kernel_t:s15:c0.c1023
tcontext=system_u:object_r:tmpfs_t:s15:c0.c1023 tclass=chr_file
Jan 11 10:29:17 aphex kernel: audit(1168529338.087:3): avc:  denied  { write }
for  pid=353 comm="nash-hotplug" name="zero" dev=tmpfs ino=715
scontext=system_u:system_r:kernel_t:s15:c0.c1023
tcontext=system_u:object_r:tmpfs_t:s0 tclass=chr_file

Additional info:
Here's my audit2allow output which once installed the system can boot just fine.
module nashhotplug 1.0;

require {
        class chr_file write;
        type kernel_t; 
        type tmpfs_t; 
        role system_r; 
};

allow kernel_t tmpfs_t:chr_file write;
Comment 1 Daniel Walsh 2007-01-11 16:51:03 EST
Fixed in selinux-policy-2.4.6-25
Comment 4 Jay Turner 2007-01-12 08:32:37 EST
QE ack for RHEL5.
Comment 5 RHEL Product and Program Management 2007-02-07 21:15:06 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.