Bug 222455 - Kernel oops when starting pcscd on a Dell Lattitude D620.
Summary: Kernel oops when starting pcscd on a Dell Lattitude D620.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Phil Knirsch
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-12 16:45 UTC by Phil Knirsch
Modified: 2015-03-05 01:18 UTC (History)
3 users (show)

Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 19:19:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0959 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5 Update 1 2007-11-08 00:47:37 UTC

Description Phil Knirsch 2007-01-12 16:45:39 UTC
Description of problem:

After installing the latest RHEL5 beta tree (RHEL5-Server-20070105) when i try
to boot up the system it hangs when trying to start the pcscd service. Only a
powercycle of the laptop brings it back to live.

After some investigation it seems that the pcscd tries to load the module for
the O2 Micro Oz776 SmartCard reader and then oopses and hangs the whole system.

Unfortunately the oops doesn't land in any logfile. If there is a way to capture
that i'd be more than happy to provide it ofc.

I've also tried the latest kernel from the nightly tree, same problem.

All this used to work before christmas, so at least for me in beta it's a
regression.

Version-Release number of selected component (if applicable):

RHEL5-Server-20070105:

o kernel-2.6.18-1.2961.el5
o kernel-2.6.18-1.3002.el5
o glibc-2.5-9
o pcsc-lite-1.3.1-7

How reproducible:

Always

Steps to Reproduce:
1. Install latest RHEL5 tree on a Dell Lattitude D620
2. Reboot
3. Watch it hang during pcscd service start
  
Actual results:

System hangs in 1st reboot after installation.

Expected results:

System should boot up properly.

Additional info:

Comment 1 Ernie Petrides 2007-09-05 22:11:49 UTC
Hi, Phil.  Does this problem still exist with the RHEL5.1 beta kernel?

Comment 2 Phil Knirsch 2007-09-06 10:56:18 UTC
Just tested it today, works correctly now and no more hangs.

So this bug can be closed.

Thanks for the fix,

Read ya, Phil

Comment 3 Ernie Petrides 2007-09-06 20:56:34 UTC
Since we suspect this problem was fixed in RHEL5.1, which is not yet
released, I'm reopening this bug so that it can be put into MODIFIED
state.  It will later be closed (after Don adds it to the advisory).

Comment 6 errata-xmlrpc 2007-11-07 19:19:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html



Note You need to log in before you can comment on or make changes to this bug.