Bug 222528 - gphoto2 gives an error when trying to read thumbnails from a digital camera
gphoto2 gives an error when trying to read thumbnails from a digital camera
Status: CLOSED DUPLICATE of bug 221831
Product: Fedora
Classification: Fedora
Component: gphoto2 (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-13 07:07 EST by Gert Vervoort
Modified: 2013-07-02 19:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-19 07:12:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gphoto2 --debug --debug-logfile=my-logfile.txt -T (272.95 KB, text/plain)
2007-01-13 07:07 EST, Gert Vervoort
no flags Details

  None (edit)
Description Gert Vervoort 2007-01-13 07:07:25 EST
Description of problem:

Not able to get thumbnails from my digital camera with as a result that gthumb
does not show any thumbnails and gtkam fails with an error. The problem can also
by reproduced using the gphoto2 command line.

Version-Release number of selected component (if applicable):

gphoto2.x86_64                           2.3.1-1.fc5 


How reproducible:

Always


Steps to Reproduce:
1. Attach a (Canon Powershot S3 IS) digital camera
2. When the "A camera has been detected" window comes up, click "Ignore".
3. run "gphoto2 -T"
  
Actual results:

[gert@apollo kw]$  gphoto2  -T
Downloading 'IMG_2987.JPG' from folder '/store_00010001/DCIM/100CANON'...
*** Error (-6: 'Unsupported operation') ***

For debugging messages, please use the --debug option.
Debugging messages may help finding a solution to your problem.
If you intend to send any error or debug messages to the gphoto
developer mailing list <gphoto-devel@lists.sourceforge.net>, please run
gphoto2 as follows:

    env LANG=C gphoto2 --debug --debug-logfile=my-logfile.txt -T

Please make sure there is sufficient quoting around the arguments.

[gert@apollo kw]$


Expected results:

That it reads the thumbnails from my digital camera, without giving an error.


Additional info:

Attached the ouput from "gphoto2 --debug --debug-logfile=my-logfile.txt -T"
Comment 1 Gert Vervoort 2007-01-13 07:07:25 EST
Created attachment 145525 [details]
gphoto2 --debug --debug-logfile=my-logfile.txt -T
Comment 2 Jindrich Novy 2007-01-18 10:46:39 EST
Could you please send the description and debug log to
gphoto-devel@lists.sourceforge.net ? The upstream should be aware of it as well
to fix it in the next release.
Comment 3 Gert Vervoort 2007-01-18 13:10:01 EST
Your mail to 'Gphoto-devel' with the subject

    [Fwd: [Bug 222528] gphoto2 gives an error when trying to read
thumbnails from a digital camera]

Is being held until the list moderator can review it for approval.

The reason it is being held:

    Post by non-member to a members-only list
Comment 4 Marcus Meissner 2007-01-18 13:38:01 EST
i approved this mail to gphoto-devel.


The problem is simple to fix:

compile libgphoto2 against libexif.

(see logfile lines:
0.000695 main(2):  + no EXIF (for special handling of EXIF files)
and:
0.640979 libgphoto2/gphoto2-filesys.c(2): Getting previews is not supported 
and libgphoto2 has been compiled without exif support.
)
Comment 5 Jindrich Novy 2007-01-18 13:55:56 EST
Strange, gphoto2 seems to be linked against libexif already:

ldd `which gphoto2` | grep libexif
        libexif.so.12 => /usr/lib/libexif.so.12 (0x00bc7000)
Comment 6 Marcus Meissner 2007-01-18 14:07:05 EST
also libgphoto2 needs to be compiled against it,
since it abstracts the "get preview" function and needs exif support for it.
Comment 7 Jindrich Novy 2007-01-18 14:30:29 EST
libgphoto2 is also compiled against libexif. I just checked the build logs:

Configuration (libgphoto2 2.3.1):

  Build
    Source code location:          .
    GP2DDB support:                no  (EXPERIMENTAL)
    Compiler:                      gcc
    libltdl includes:              -I${top_srcdir}/libltdl
    libltdl library:               ${top_builddir}/libltdl/libltdlc.la

  Features
    Use translations:              yes
    JPEG mangling support:         yes
    build API docs with gtk-doc:   no (not requested)
    libexif:                       yes

    Subprojects:                   libltdl libgphoto2_port

Comment 8 Marcus Meissner 2007-01-18 14:40:39 EST
strange, the users logfile did not say so.

What does:

gphoto2 --version 

say?

for me (self compiled) it says:
gphoto2         2.3.1.2.trunk  gcc, popt(m), exif, cdk, aa, jpeg, readline
libgphoto2      2.3.1.3.trunk  gcc, ltdl, EXIF  (<<< most important one)
libgphoto2_port 0.7.2          gcc, ltdl, USB, serial resmgr locking
Comment 9 Jindrich Novy 2007-01-18 14:47:10 EST
It says:

gphoto2 2.3.1

Copyright (c) 2000-2006 Lutz Mueller and others

gphoto2 comes with NO WARRANTY, to the extent permitted by law. You may
redistribute copies of gphoto2 under the terms of the GNU General Public
License. For more information about these matters, see the files named COPYING.

This version of gphoto2 is using the following software versions and options:
gphoto2         2.3.1          gcc, popt(m), exif, no cdk, no aa, jpeg, no readline
libgphoto2      2.3.1          gcc, no ltdl, EXIF
libgphoto2_port 0.7.1          gcc, no ltdl, USB, serial baudboy locking
Comment 10 Gert Vervoort 2007-01-18 14:49:11 EST
Package as installed as part of FC5:
gphoto2.x86_64                           2.3.1-1.fc5 


[gert@apollo tmp]$ gphoto2 --version
gphoto2 2.3.1

Copyright (c) 2000-2006 Lutz Mueller and others

gphoto2 comes with NO WARRANTY, to the extent permitted by law. You may
redistribute copies of gphoto2 under the terms of the GNU General Public
License. For more information about these matters, see the files named COPYING.

This version of gphoto2 is using the following software versions and options:
gphoto2         2.3.1          gcc, popt(m), exif, no cdk, no aa, jpeg,
readlinelibgphoto2      2.3.1          gcc, no ltdl, no EXIF
libgphoto2_port 0.7.1          gcc, no ltdl, USB, serial baudboy locking
[gert@apollo tmp]$
Comment 11 Jindrich Novy 2007-01-18 14:51:36 EST
Hm, I checked only the i386 builds, I will have a look at the x86_64 builds
tomorrow.
Comment 12 Jindrich Novy 2007-01-19 07:12:47 EST
Ok, seems to be FC5 specific breakage because configure script is unable to
detect the FC5 version of libexif-devel.

*** This bug has been marked as a duplicate of 221831 ***

Note You need to log in before you can comment on or make changes to this bug.