Bug 222532 - no centrino speedstep with xen
no centrino speedstep with xen
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-13 08:47 EST by Jörg Prante
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-15 11:28:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jörg Prante 2007-01-13 08:47:28 EST
Description of problem:

no speedstep support with xen

Version-Release number of selected component (if applicable):

xen-3.0.3-1.fc6
kernel-xen-2.6.18-1.2869.fc6
cpuspeed-1.2.1-1.46.fc6
CPU: Intel(R) Core(TM)2 CPU         T7600  @ 2.33GHz
Machine: Dell Precision Mobile Workstation M90

How reproducible:

always

Steps to Reproduce:
1. Boot into kernel-xen
2. Check /sys/devices/system/cpu/cpu0/cpufreq
3. it is not present
  
Actual results:
no speedstep

Expected results:
The centrino speedstep should be available due to 
a patch by Matt Yourst
http://lkml.org/lkml/2006/4/14/151


Additional info:
There is a release note in cpuspeed-1.2.1-1.43
http://fedoranews.org/cms/node/2386
that it does not start on xen kernels.
If xen kernels should provide speedstep, this should be re-enabled as well.
Comment 1 Stephen Tweedie 2007-01-15 11:28:57 EST
The reason that frequency scaling is disabled is not because speedstep doesn't
work under Xen.  It *does* work, if enabled --- but it completely fails to take
account of activity in domains other than the host dom0.  So if you have a guest
domU busy on the machine and dom0 is idle, frequency scaling will slow the host
down to its slowest setting.

In the future we hope for this to be fixed upstream, but we have no plans to
address it in FC-6 at this time.
Comment 2 Jörg Prante 2007-01-17 17:49:11 EST
Sorry, I forgot a diagnostic message. The FC6 xen kernel does not load the
module acpi_cpufreq during boot and is therefore not able to set up speedstep.

FATAL: module acpi_cpufreq not found

Please advise how I can load this module under xen, since you mention "it *does*
work".

The reason is: on dual core laptops, missing speedstep is annoying since energy
consumption and heat is significantly higher.

I think slowing down the whole activity of all xen domains is the expected
behavior and I could live with only accounting of cpu activity in dom0.

 

Note You need to log in before you can comment on or make changes to this bug.