Bug 222554 - fix IPv6 support in PR_StringToNetAddr, PR_GetAddrInfoByName
fix IPv6 support in PR_StringToNetAddr, PR_GetAddrInfoByName
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nspr (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kai Engert (:kaie)
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-13 21:38 EST by Rich Megginson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: nspr-4.6.4-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-16 14:42:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix IPv6 in nspr 4.6.4 (15.20 KB, patch)
2007-01-13 21:38 EST, Rich Megginson
no flags Details | Diff
nspr-ipv6-hpux.patch (1.39 KB, patch)
2007-01-15 17:04 EST, Wan-Teh Chang
no flags Details | Diff
nspr-ipv6-numerichost.patch (9.16 KB, patch)
2007-01-15 17:07 EST, Wan-Teh Chang
no flags Details | Diff

  None (edit)
Description Rich Megginson 2007-01-13 21:38:59 EST
Description of problem:
NSPR does not support all types of IPv6 addresses.  This patch fixes that.

Version-Release number of selected component (if applicable):
This patch has been generated against NSPR v4.6.4

How reproducible:
Try NSPR with a link local address.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
We've been running nspr 4.6.3 for a few months with this patch, and Wan Teh has
reviewed it.  Unfortunately, upstream is very busy with FIPS work and hasn't had
a chance to merge this in.  The Mozilla LDAP C SDK and the Fedora Directory
Server need this patch to be able to support all types of IPv6 addresses.
Comment 1 Rich Megginson 2007-01-13 21:38:59 EST
Created attachment 145537 [details]
patch to fix IPv6 in nspr 4.6.4
Comment 2 Rich Megginson 2007-01-13 21:41:11 EST
One more note: we've been calling our internal version 4.6.3.1 and 4.6.4.1 - the
extra .1 to denote this is the base version of NSPR with the IPv6 patch.  I'm
not sure what the versioning conventions are for fedora.  Also, this patch needs
to be applied to fc-5, fc-6, and devel.
Comment 3 Wan-Teh Chang 2007-01-15 16:40:39 EST
Comment on attachment 145537 [details]
patch to fix IPv6 in nspr 4.6.4

Kai, please separate this patch into two patches.

1. nspr-ipv6-hpux.patch: this contains the changes to _hpux.h,
   configure, and configure.in.  The upcoming NSPR 4.6.5 release
   will have these changes.  See
   https://bugzilla.mozilla.org/show_bug.cgi?id=329807

2. nspr-ipv6-numerichost.patch: this contains the rest of the
   changes in this patch.  See
   https://bugzilla.mozilla.org/show_bug.cgi?id=34843
Comment 4 Wan-Teh Chang 2007-01-15 17:04:22 EST
Created attachment 145625 [details]
nspr-ipv6-hpux.patch

I used gendiff to regenerate the patch and split it into two patches.
This is the first patch, nspr-ipv6-hpux.patch.	This patch won't be
necessary when NSPR 4.6.5 is released.
Comment 5 Wan-Teh Chang 2007-01-15 17:07:28 EST
Created attachment 145626 [details]
nspr-ipv6-numerichost.patch

This is the second patch, nspr-ipv6-numerichost.patch.

Please also remove the obsolete patches
nspr-4.6.1-disable-gcc-ansi.patch and
nspr-4.6.1-gcc-visibility.patch.  Thanks.
Comment 6 Kai Engert (:kaie) 2007-01-16 00:42:39 EST
Comment on attachment 145625 [details]
nspr-ipv6-hpux.patch

(In reply to comment #4)
> nspr-ipv6-hpux.patch
> 
> I used gendiff to regenerate the patch and split it into two patches.
> This is the first patch, nspr-ipv6-hpux.patch.	This patch won't be
> necessary when NSPR 4.6.5 is released.

This patch seems to be completely limited to HPUX. The RPM does not get built
on HPUX. I conclude this patch is not necessary for the Linux RPM.
Comment 7 Kai Engert (:kaie) 2007-01-16 14:42:49 EST
nspr-4.6.4-0.5.1.fc5
nspr-4.6.4-0.6.1.fc6
nspr-4.6.4-2

Note You need to log in before you can comment on or make changes to this bug.