Bug 222561 - Missing build dependency tcl-devel
Missing build dependency tcl-devel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-imaging (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: José Matos
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-14 06:45 EST by Felix Schwarz
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 06:42:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Schwarz 2007-01-14 06:45:26 EST
There is a missing build dependency tcl-devel for python-imaging. If you do
"rpmbuild --rebuild" without having tcl-devel installed, you will get error
messages such as "tcl.h not found".
Comment 1 José Matos 2007-01-14 18:41:45 EST
That case is covered by BuildRequires tk-devel:

$ rpm -q --requires tk-devel
libX11-devel
libtk8.4.so
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
tcl-devel = 8.4.13
tk = 8.4.13-3.fc6
Comment 2 José Matos 2007-02-07 06:42:29 EST
The dependency is correct, since tk-devel requires tcl-devel, else it would 
not build in mock.

$ rpm -q --requires python-imaging
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.3)
libc.so.6(GLIBC_2.3.4)
libc.so.6(GLIBC_2.4)
libfreetype.so.6
libjpeg.so.62
libpthread.so.0
libpthread.so.0(GLIBC_2.0)
libtcl8.4.so
libtk8.4.so
libz.so.1
python(abi) = 2.4
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)
tkinter

Note You need to log in before you can comment on or make changes to this bug.