Bug 222588 - Shrink To/Cc/Bcc setting doesn't work in non-C locale
Shrink To/Cc/Bcc setting doesn't work in non-C locale
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
6
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-14 17:08 EST by Markus Berg
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-06 00:39:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markus Berg 2007-01-14 17:08:29 EST
Description of problem:
With the latest update to Evolution, the "Shrink To/Cc/Bcc headers" function no
longer functions in my locale (sv_SE.UTF-8).  It works fine in locale C.

Version-Release number of selected component (if applicable):
evolution-2.8.2.1-3.fc6

How reproducible:
Every time.

Steps to Reproduce:
1. Start Evolution with "LC_ALL=sv_SE.UTF-8 evolution"
2. Open an email with a huge number of To- or Cc-addresses
  
Actual results:
All the To/Cc/Bcc addresses are shown, regardless of the "Shrink To/Cc/Bcc
headers" setting.  This causes the actual contents of the email to be pushed off
screen.

Expected results:
The number of header lines should be truncated to the number number of lines
specified in the preferences.

Additional info:
A work-around is to start evo with "LC_MESSAGES=C evolution"
Comment 1 Matthew Barnes 2007-01-14 19:35:25 EST
Thanks for the bug report.  Do you recall what version you updated from?
Comment 2 Markus Berg 2007-01-15 02:19:54 EST
No, I don't know what the previous version was.  The current one was installed
with the latest "yum update" sometime last week (or possibly last weekend). 
Judging by the file dates on the fedora-updates repo, I'm guessing that the
previous version I was using was evolution-2.8.2.1-2.fc6.x86_64.rpm (dec 4'th 2006).
Comment 3 Markus Berg 2007-01-15 11:00:16 EST
Ok, so I did some digging, and reverted my evo version progressively all the way
back to 2.8.0...  without any luck.  The bug still appears even in 2.8.0.  Strange.

I distinctly remember this feature working on initial fc6-installation though,
because the lack of it had been bugging me in fc5.

This leads me to believe that it may have been another update that broke the
feature.
Comment 4 Matthew Barnes 2007-10-05 01:02:38 EDT
Is this problem still present in Fedora 8 Test 2 or later?
Comment 5 Markus Berg 2007-10-05 11:26:30 EDT
I don't know.  I'm using Fedora 7, and it's still a problem with the latest evo.
 I worked around it by adding "LC_MESSAGES=C" in /etc/sysconfig/i18n.
Comment 6 Matthew Barnes 2007-10-06 00:39:34 EDT
Seems to be working correctly for me with Evolution 2.12.  Followed the steps to
reproduce as you described in comment #0.

If you still encounter the problem using Fedora 8, please re-open this bug and
attach a sample message that illustrates the problem?

Note You need to log in before you can comment on or make changes to this bug.