Bug 222633 - unable to commit Japanese input in mail
unable to commit Japanese input in mail
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: scim-bridge (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-15 07:54 EST by Y. N.
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-04 23:28:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Y. N. 2007-01-15 07:54:39 EST
Description of problem:

1.Japanese was input to the mail text. 

2.To convert the Chinese character, the space key was pushed. 

3.So then, Thunderbird canceled.

I cannot input japanese.

Version-Release number of selected component (if applicable):

# uname -r
2.6.18-1.2869.fc6
# rpm -qa |grep thunderbird
thunderbird-1.5.0.9-2.fc6

How reproducible:
Every time, it goes out. 

Steps to Reproduce:
1.Japanese was input to the mail text. 
2.To convert the Chinese character, the space key was pushed. 
3.So then, Thunderbird canceled.
  
Actual results:
Thunderbird was forced ending.

Expected results:
Thunderbird wasn't forced ending.
I can input japanese.

Additional info:
This problem did not occur until updating it to thunderbird-1.5.0.9-2.fc6.

Please give mail to me when material (file) is necessary.
Comment 2 Jens Petersen 2007-01-21 20:46:35 EST
It works ok for me.

Are you using scim-anthy?
Comment 3 Y. N. 2007-01-22 11:11:05 EST
Yes, I'm using scim-anthy. 


The error with scim-anthy often occurs in the system. However, it is only
thunderbird in Japanese conversion that the application cancels. 

The following are the output results of the rpm command. 
------------------------------------------------------
# rpm -ql scim
/etc/X11/xinit/xinput.d
/etc/X11/xinit/xinput.d/scim.conf
/etc/scim
/etc/scim/config
/etc/scim/global
/usr/bin/scim
/usr/bin/scim-config-agent
/usr/bin/scim-restart
/usr/bin/scim-setup
/usr/lib64/scim-1.0
/usr/lib64/scim-1.0/1.4.0
/usr/lib64/scim-1.0/1.4.0/Filter
/usr/lib64/scim-1.0/1.4.0/Filter/sctc.so
/usr/lib64/scim-1.0/1.4.0/FrontEnd
/usr/lib64/scim-1.0/1.4.0/FrontEnd/socket.so
/usr/lib64/scim-1.0/1.4.0/FrontEnd/x11.so
/usr/lib64/scim-1.0/1.4.0/Helper
/usr/lib64/scim-1.0/1.4.0/Helper/setup.so
/usr/lib64/scim-1.0/1.4.0/IMEngine
/usr/lib64/scim-1.0/1.4.0/IMEngine/rawcode.so
/usr/lib64/scim-1.0/1.4.0/SetupUI
/usr/lib64/scim-1.0/1.4.0/SetupUI/aaa-frontend-setup.so
/usr/lib64/scim-1.0/1.4.0/SetupUI/aaa-imengine-setup.so
/usr/lib64/scim-1.0/1.4.0/SetupUI/panel-gtk-setup.so
/usr/lib64/scim-1.0/scim-helper-launcher
/usr/lib64/scim-1.0/scim-helper-manager
/usr/lib64/scim-1.0/scim-launcher
/usr/lib64/scim-1.0/scim-panel-gtk
/usr/share/applications/fedora-scim-setup.desktop
/usr/share/doc/scim-1.4.4
/usr/share/doc/scim-1.4.4/AUTHORS
/usr/share/doc/scim-1.4.4/COPYING
/usr/share/doc/scim-1.4.4/ChangeLog
/usr/share/doc/scim-1.4.4/NEWS
/usr/share/doc/scim-1.4.4/README
/usr/share/doc/scim-1.4.4/TODO
/usr/share/locale/cs/LC_MESSAGES/scim.mo
/usr/share/locale/de/LC_MESSAGES/scim.mo
/usr/share/locale/fi/LC_MESSAGES/scim.mo
/usr/share/locale/fr/LC_MESSAGES/scim.mo
/usr/share/locale/it/LC_MESSAGES/scim.mo
/usr/share/locale/ja/LC_MESSAGES/scim.mo
/usr/share/locale/ko/LC_MESSAGES/scim.mo
/usr/share/locale/pa/LC_MESSAGES/scim.mo
/usr/share/locale/zh_CN/LC_MESSAGES/scim.mo
/usr/share/locale/zh_TW/LC_MESSAGES/scim.mo
/usr/share/pixmaps/scim-setup.png
/usr/share/scim
/usr/share/scim/icons
/usr/share/scim/icons/down.png
/usr/share/scim/icons/full-letter.png
/usr/share/scim/icons/full-punct.png
/usr/share/scim/icons/half-letter.png
/usr/share/scim/icons/half-punct.png
/usr/share/scim/icons/help.png
/usr/share/scim/icons/keyboard.png
/usr/share/scim/icons/left.png
/usr/share/scim/icons/menu.png
/usr/share/scim/icons/pin-down.png
/usr/share/scim/icons/pin-up.png
/usr/share/scim/icons/rawcode.png
/usr/share/scim/icons/right.png
/usr/share/scim/icons/sctc-sc-to-tc.png
/usr/share/scim/icons/sctc-tc-to-sc.png
/usr/share/scim/icons/sctc.png
/usr/share/scim/icons/setup.png
/usr/share/scim/icons/trademark.png
/usr/share/scim/icons/up.png
------------------------------------------------------
Comment 4 Jens Petersen 2007-01-22 18:42:53 EST
(In reply to comment #3)
> The error with scim-anthy often occurs in the system.

Sorry what error occurs often?

> However, it is only thunderbird in Japanese conversion
> that the application cancels. 

Do you have scim-bridge-gtk installed?

I am a Japanese thunderbird user too but I am not able to reproduce
your problem.  Can you please describe how to reproduce the problem
in detail?  Thank you.
Comment 5 Y. N. 2007-01-23 07:35:46 EST
>Sorry what error occurs often?

Japanese is registered in the dictionary. 
Scim doesn't start when registering many times because registration 
is not reflected. 

>Do you have scim bridge-gtk installed?

# rpm -qa |grep scim-bridge-gtk
scim-bridge-gtk-0.4.9-1.fc6
scim-bridge-gtk-0.4.9-1.fc6

>I am a Japanese thunderbird user too but I am not able to reproduce
>your problem.  Can you please describe how to reproduce the problem
>in detail?  Thank you.

Sorry, The cause of generation is not understood though 
reproducibility can be taken. 
Comment 6 Y. N. 2007-01-23 09:40:42 EST
- Additional Information -
When the error occurred, the following outputs were able to be 
confirmed to the system log. 
However, anything did not go out of thunderbird-debuginfo. 

■Systemlog.out
Jan 23 23:30:14 localhost scim-bridge: An IOException at
scim_bridge_messenger_receive_message (): The connection was reset from the
other party.
Comment 7 Jens Petersen 2007-01-23 19:15:30 EST
Ok, thank you for the information.

Can you try running thunderbird without scim-bridge like this:

  GTK_IM_MODULE=scim thunderbird

to see if that makes a difference.
Comment 8 Y. N. 2007-01-24 07:34:19 EST
GTK_IM_MODULE was changed to scim thunderbird.

# echo $GTK_IM_MODULE
scim thunderbird

Bud thunderbird canceled.

It is a system log that the following output at that time. 
Jan 23 23:30:14 localhost scim-bridge: An IOException at
scim_bridge_messenger_receive_message (): The connection was reset from the
other party.

Additional Informartion
The error doesn't occur if the blank is input to the head. 
Comment 10 Jens Petersen 2007-01-24 17:30:29 EST
(In reply to comment #8)
> # echo $GTK_IM_MODULE
> scim thunderbird

No, that should be just "scim".

ie can try running:

$ GTK_IM_MODULE="scim" thunderbird

or

$ export GTK_IM_MODULE="scim"
$ thunderbird

please.
Comment 11 Y. N. 2007-01-25 09:00:28 EST
Sorry.

$ export GTK_IM_MODULE=scim
$ echo $GTK_IM_MODULE
scim
$ thunderbird

The problem was solved.

Should I not use scim-bridge?

Thanks ens Petersen
Comment 12 Ryo Dairiki 2007-01-28 07:26:26 EST
This bug is caused by a patch to prevent cursor flicking problem.
(Almost the same patch has already been applied on scim-1.4.5)

I've applied another patch on the cvs latest of SCIM-Bridge.
Please test it. :)
Comment 13 Jens Petersen 2007-02-25 20:00:38 EST
Thanks!  I built scim-bridge-0.4.10-1.fc6 for updates testing.
Comment 14 Jens Petersen 2007-04-04 23:28:55 EDT
Closing this.  Please reopen of you still see problems.

Note You need to log in before you can comment on or make changes to this bug.