Bug 222741 - preinstall script makes wrong assumtions
preinstall script makes wrong assumtions
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: screen (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Brock Organ
:
: 223572 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-15 17:13 EST by Fritz Elfert
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: screen-4.0.3-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-16 07:56:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fritz Elfert 2007-01-15 17:13:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Description of problem:
From last night's yum update:

nscd: unrecognized service
error: %pre(screen-4.0.3-1.x86_64) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping screen-4.0.3-1

It seems, that screen's preinstall-script wants to restart nscd which is not installed here ...
Running yum update manually fails the same way.

Version-Release number of selected component (if applicable):
screen-4.0.3-1.x86_64

How reproducible:
Always


Steps to Reproduce:
1.yum update screen
2.
3.

Actual Results:
Should update screen

Expected Results:
Update fails with the described error

Additional info:
Comment 1 Fritz Elfert 2007-01-15 17:31:44 EST
running qpm -qp --scripts /var/cache/yum/updates/packages/screen-4.0.3-1.x86_64.rpm
reveals this:

preinstall scriptlet (using /bin/sh):
/usr/sbin/groupadd -g 84 -r -f screen
service nscd force-reload

The last line probably should be replaced by something like:
if test -f /etc/init.d/nscd ; then
  service nscd force-reload
fi

Comment 2 Marcela Mašláňová 2007-01-16 07:33:36 EST
related to #222785
Comment 3 Marcela Mašláňová 2007-01-16 07:56:02 EST
Hello,
thanks for info. I change whole spec file. You'll can try after update (few
days) and let me know if you want.

Have a nice day,
Marcela
Comment 4 Marcela Mašláňová 2007-01-22 03:21:34 EST
*** Bug 223572 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.