Bug 222865 - Wrong copy of Typeable.h included in ghc66 package
Wrong copy of Typeable.h included in ghc66 package
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ghc (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-16 11:55 EST by Bryan O'Sullivan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-19 01:18:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan O'Sullivan 2007-01-16 11:55:22 EST
Description of problem:

In the ghc source tree, there are two files named Typeable.h:

libraries/base/include/Typeable.h
libraries/network/include/Typeable.h

The second one is a vastly cut-down version of the first, and isn't actually
usable for much of anything.  Unfortunately, it's the version that is installed
in the ghc66 binary package.  This means that any third-party package that tries
to #include "Typeable.h" will fail to compile with a parse error.

This affects, for example, the hs-plugins package.

Version-Release number of selected component (if applicable): 6.6
Comment 1 Bryan O'Sullivan 2007-01-16 13:36:14 EST
Looks like an upstream bug: http://hackage.haskell.org/trac/ghc/ticket/1106
Comment 2 Jens Petersen 2007-01-19 00:57:36 EST
If the network package build-depends on base,
is the cutdown include filed needed even to build?
Comment 3 Jens Petersen 2007-01-21 17:28:26 EST
Seems to build ok without it.
Comment 4 Jens Petersen 2007-01-21 17:53:06 EST
Should be fixed first in ghc-6.6-2.fc7.

The file is also here for those that need it and don't want to download ghc-6.6
just to get it:
8db402b7925755cbb31a466500a34293
http://darcs.haskell.org/packages/base/include/Typeable.h (2.2kB).
Comment 5 Jens Petersen 2007-07-19 01:18:47 EDT
ghc-6.6.1 has been available for fc6 for a while.

Note You need to log in before you can comment on or make changes to this bug.