Bug 222879 - squirrelmail ja_JP patches break build
squirrelmail ja_JP patches break build
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: squirrelmail (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Bacovsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-16 13:14 EST by Warren Togami
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-24 08:25:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2007-01-16 13:14:01 EST
+ msgfmt ./locale/ja_JP/LC_MESSAGES/mini.po -c -o ./locale/ja_JP/LC_MESSAGES/mini.mo
./locale/ja_JP/LC_MESSAGES/mini.po:6: nplurals = 1...
./locale/ja_JP/LC_MESSAGES/mini.po:46: ...but some messages have 2 plural forms
msgfmt: found 1 fatal error
error: Bad exit status from /var/tmp/rpm-tmp.46046 (%build)

It seems that something in FC7 is pickier about .po file contents, causing a new
build failure that did not exist in FC6.  This might be caused by the ugly
patches we added for our own Japanese support.

I need help integrating all those patches into upstream squirrelmail.
Comment 1 Tomas 2007-01-27 06:30:17 EST
See
http://squirrelmail.svn.sourceforge.net/viewvc/squirrelmail/trunk/locales/locale/ja_JP/LC_MESSAGES/mini.po?r1=10192&r2=11678

remove msgstr[1] lines in translated strings with plural forms. Japanese don't
have second form and gettext 0.15 added more Plural-Forms header checks.

Issue is fixed in squirrelmail 1.4.9-20070106 translation packages. It was not
fixed in last 1.4.8 translations, because issue was reported after
1.4.8-20060903 release.
Comment 2 Martin Bacovsky 2007-04-24 08:25:10 EDT
This issue should be fixed in rawhide (squirrelmail-1.4.9a-2.fc7)

Note You need to log in before you can comment on or make changes to this bug.