Bug 222914 - /bin/sh: @MKINSTALLDIRS@: No such file or directory
/bin/sh: @MKINSTALLDIRS@: No such file or directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: w3m (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag Nemade
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-16 16:01 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: w3m-0.5.1-16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-21 04:57:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2007-01-16 16:01:38 EST
Description of problem:
Did you ever try to build w3m using the packages autoconf-2.61-2 and/or 
automake-1.10-2? I guess not, because it will die this way:

[...]
make[1]: Leaving directory `/usr/src/rpm/BUILD/w3m-0.5.1/scripts'
NLSTARGET="po"; for subdir in $NLSTARGET; \
        do \
         (cd $subdir && make install); \
        done
make[1]: Entering directory `/usr/src/rpm/BUILD/w3m-0.5.1/po'
/bin/sh @MKINSTALLDIRS@ /var/tmp/w3m-root/usr/share
/bin/sh: @MKINSTALLDIRS@: No such file or directory
make[1]: *** [install-data-yes] Error 127
make[1]: Leaving directory `/usr/src/rpm/BUILD/w3m-0.5.1/po'
make: *** [install-po] Error 2

Version-Release number of selected component (if applicable):
w3m-0.5.1-15
automake-1.10-2
autoconf-2.61-2

How reproducible:
Everytime, see above.

Actual results:
Rebuilding ends with an error message.

Expected results:
No error and working rebuild ;-)

Additional info:
BTW, why did you build w3m-0.5.1-15 as w3m-0.5.1-15.fc6 (note the FC6) for 
Rawhide AKA Fedora Core Development? Why isn't this .fc7 - was it submitted to 
the wrong branch/tag or so? This would explain why the w3m package was built 
successfully.

This bug report is similar like bug #217186 and bug #220715. Maybe you're able 
to adapt util-linux-2.13-mkdir_p.patch or another existing one to save work...
Comment 1 Robert Scheck 2007-02-10 16:40:32 EST
Ping?
Comment 2 Parag Nemade 2007-02-21 04:57:31 EST
Fixed in w3m-0.5.1-16.fc7. Thanks for your feedback.

Note You need to log in before you can comment on or make changes to this bug.