Bug 222927 - make autoupdates a bit more quiet
Summary: make autoupdates a bit more quiet
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: apt (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-16 21:33 UTC by Pierre Ossman
Modified: 2008-01-12 09:13 UTC (History)
1 user (show)

Fixed In Version: 0.5.15lorg3.2-10.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-12 09:13:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pierre Ossman 2007-01-16 21:33:47 UTC
The current automatic update script is a bit chatty. Ideally, it would have no
output if there are no updates. So I propose this change:

if /usr/bin/apt-get -qq update; then
    /usr/bin/apt-get dist-upgrade -qq --check-only
    if [ $? -eq 100 ]; then
        /usr/bin/apt-get -q -y $OPTS dist-upgrade
    fi
fi

Comment 1 Axel Thimm 2007-05-23 10:36:15 UTC
Why not simply

/usr/bin/apt-get -qq update && /usr/bin/apt-get -qq -y $OPTS dist-upgrade

Comment 2 Pierre Ossman 2007-05-23 11:08:58 UTC
Because you want output when it actually does something. You usually need to
verify that services still work after upgrades.

Comment 3 Fedora Update System 2007-06-04 04:12:31 UTC
apt-0.5.15lorg3.2-10.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Axel Thimm 2007-06-04 09:48:17 UTC
Pierre, can you check the package in updates-testing? Thanks!

Comment 5 Pierre Ossman 2007-06-04 10:09:03 UTC
The version in testing (apt-0.5.15lorg3.2-10.fc7) has the same cron job as the
previous version.

Also, it breaks the synaptic package since it changed the name of a lib.

OT: And how did you get F-7 stuff into the repo? I've been waiting for several
days to get an update in there that other packages need to build.

Comment 6 Axel Thimm 2007-06-04 10:34:06 UTC
(In reply to comment #5)
> The version in testing (apt-0.5.15lorg3.2-10.fc7) has the same cron job as the
> previous version.

How can that be? I just checked it was properly committed to cvs. :(
I guess I need to investigate what went wrong. :/

> Also, it breaks the synaptic package since it changed the name of a lib.

Then probably the synaptic package needs a rebuild. Can you post the output of
the error? Perhaps in a separate bug? Thanks!

> OT: And how did you get F-7 stuff into the repo? I've been waiting for several
> days to get an update in there that other packages need to build.

Log in on admin.fedoraproject.org/updates and setup an update for your package.
There are instructions on the very first screen after logging in.


Comment 7 Panu Matilainen 2007-06-04 10:41:26 UTC
Ugh... yeah, synaptic needs a rebuild, thanks to apt encoding glibc version into
it's soname (don't ask me why, probably some ancient historical artifact) and
glibc version has changed from 2.5 -> 2.6 since apt+synaptic have been last
rebuilt. 

There's a yum bug present here as well: it should notice that synaptic's
dependencies can't be met, but it's not. Looks like another case of
https://lists.dulug.duke.edu/pipermail/yum-devel/2007-June/003738.html

Comment 8 Axel Thimm 2007-06-04 10:54:47 UTC
The wonders of deciding not to do a final mass rebuild before freezing F7. :(

I'll schedule a synaptic rebuild then.


Comment 9 Fedora Update System 2007-06-08 15:58:41 UTC
apt-0.5.15lorg3.2-10.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Pierre Ossman 2007-06-10 19:39:46 UTC
Bad bot! No treat for you!

Comment 11 Axel Thimm 2007-06-10 20:58:38 UTC
(In reply to comment #5)
> The version in testing (apt-0.5.15lorg3.2-10.fc7) has the same cron job as the
> previous version.

OK, here is the CVS content:

http://cvs.fedora.redhat.com/viewcvs/*checkout*/rpms/apt/F-7/apt.cron?rev=1.2&only_with_tag=apt-0_5_15lorg3_2-10_fc7

and the diff

http://cvs.fedora.redhat.com/viewcvs/rpms/apt/F-7/apt.cron?r1=1.1&r2=1.2&only_with_tag=apt-0_5_15lorg3_2-10_fc7

This is what was committed to the buildsystem, it has the proper tag as well. I
don't know why the cron diff wasn't taken. :/

Comment 12 Pierre Ossman 2007-06-11 08:16:17 UTC
How odd. No idea what the problem is, but I can verify that it didn't make it to
the package:

[root@poseidon ~]# rpm -q apt
apt-0.5.15lorg3.2-10.fc7
[root@poseidon ~]# rpm -V apt
S.5....T c /etc/apt/apt.conf

And a fresh download with cpio unpacking still gives me the old cron file.

Comment 13 Pierre Ossman 2007-07-11 11:54:13 UTC
Apt just got update to apt-0.5.15lorg3.92-1.fc8, but it still has the old cron
job. Very odd.

Comment 14 Axel Thimm 2007-08-03 09:30:24 UTC
Can you check the latest update? Thanks!

Comment 15 Pierre Ossman 2007-08-04 21:51:21 UTC
'fraid not :/

[root@poseidon ~]# rpm -q apt
apt-0.5.15lorg3.92-2.fc8
[root@poseidon ~]# md5sum /etc/cron.daily/apt.cron 
0437cf5f560bb5529f7d6e3bda970322  /etc/cron.daily/apt.cron
[root@poseidon ~]# rpm -V apt
S.5....T c /etc/apt/apt.conf

But I think I've found your problem. :)

Your spec file doesn't mention apt.cron as a source. Hence, the srpm doesn't get
a copy of it and neither does the resulting rpms. Also, you install a cron
script from inside the apt tarball:

install -Dpm 755 contrib/apt-cron/apt.cron
%{buildroot}/%{_sysconfdir}/cron.daily/apt.cron


Comment 16 Pierre Ossman 2007-09-27 06:58:02 UTC
Yo hooo!

Alex, the bug has been found. Any time over for implementing it? (Preferably for
FC6 through devel)

Comment 17 Panu Matilainen 2008-01-12 09:13:59 UTC
This should be fixed in rawhide now (by making apt.cron more quiet upstream :)


Note You need to log in before you can comment on or make changes to this bug.