Bug 222974 - [mail] [Print] Footer is printed as square box for english Numeric
[mail] [Print] Footer is printed as square box for english Numeric
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
: i18n, Reopened
Depends On: 222966
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-17 03:50 EST by Mayank Jain
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-22 10:32:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The problem is not yet fixed in the new upstream code which uses gtk-print instead of libgnomeprint (28.85 KB, image/png)
2007-01-30 05:49 EST, Mayank Jain
no flags Details
Problem solved in new gtk-print migration (170.67 KB, image/png)
2007-02-22 10:02 EST, Mayank Jain
no flags Details
Post Script File showing that No Page Number even more than 2 pages are there (236.48 KB, application/pdf)
2007-05-02 01:18 EDT, A S Alam
no flags Details
PDF printed in gu_IN locale (44.58 KB, application/pdf)
2007-10-22 10:31 EDT, Matthew Barnes
no flags Details

  None (edit)
Description Mayank Jain 2007-01-17 03:50:27 EST
+++ This bug was initially created as a clone of Bug #222966 +++

Description of problem:
in gu_IN, create new mail, then print it (or check print preview), FOOTer is
showing 2 square boxes

Version-Release number of selected component (if applicable):
evolution-2.9.4-4.fc7

How reproducible:
Everytime during typing Mail

Steps to Reproduce:
1. run evolution in gu_IN locale
2. create new mail
3. print it (or Print preview is enough
4. Check Footer (Page 1 out of X)

Actual results:
Print square

Expected results:
Numeric should print

Additional info:
gedit/evolution-Cal is printing ok

-- Additional comment from aalam@redhat.com on 2007-01-17 01:14 EST --
Created an attachment (id=145776)
Post script file attached


-- Additional comment from llim@redhat.com on 2007-01-17 01:18 EST --
Proposed to 5.1.
Comment 1 Mayank Jain 2007-01-18 02:01:02 EST
Confirming this behavior in almost all indic languages. Some indic languages
which do not show this behavior are pa_IN - reason can be that the utf-8 string
might be somehow equivalent to the ascii string in length. 
Comment 2 Mayank Jain 2007-01-30 05:49:15 EST
Created attachment 146907 [details]
The problem is not yet fixed in the new upstream code which uses gtk-print instead of libgnomeprint
Comment 3 Mayank Jain 2007-02-01 00:23:58 EST
Waiting till the upstream work of migration to gtk-print finishes. This will
prevent dual & parallel work on the same issues.
Comment 4 Mayank Jain 2007-02-12 02:52:50 EST
*** Bug 226730 has been marked as a duplicate of this bug. ***
Comment 5 Mayank Jain 2007-02-12 02:56:26 EST
Adding libgnomeprintui maintainer to the CC list.

Kristian, what do you think of this bug? And also Bug 226730?

Thanks,
Mayank
Comment 6 Mayank Jain 2007-02-22 10:02:21 EST
Created attachment 148571 [details]
Problem solved in new gtk-print migration

The migration to gtk-print solved this problem.
Comment 7 Matthew Barnes 2007-02-22 10:09:44 EST
That's good news.  Closing this bug then.
Comment 8 Mayank Jain 2007-02-22 10:13:50 EST
But Matthew, this code is not yet in our packages... QE guys would have no way
to check this... shouldnt this remain open & be set to MODIFIED when you've
built Evo with gtk-print code?
Comment 9 Matthew Barnes 2007-02-22 10:23:27 EST
Actually it's there already.  The GtkPrint migration landed in Evolution 2.9.6.
Rawhide is currently carrying Evolution 2.9.91.
Comment 10 Matthew Barnes 2007-02-22 10:28:45 EST
That is, unless this was a recently committed change (post-2.9.91).

Am I being too hasty?
Comment 11 Matthew Barnes 2007-02-22 13:28:15 EST
Re-opening and setting to MODIFIED so QE and test this.
Comment 12 Mayank Jain 2007-02-23 00:18:30 EST
Thanks Matthew :)
Comment 13 A S Alam 2007-05-02 01:18:45 EDT
Created attachment 153916 [details]
Post Script File showing that No Page Number even more than 2 pages are there
Comment 14 A S Alam 2007-05-02 01:30:47 EDT
No Page Number was shown,
can someone please help me where did it went wrong?

tested with following version:
---
evolution-2.10.1-4.fc7
gutenprint-cups-5.0.0.99.1-2.fc7
libgnomeprint22-2.18.0-1.fc7
libgnomeprintui22-2.18.0-1.fc7
---

Comment 15 Hu Zheng 2007-10-22 05:05:36 EDT
The new code didn't add the page number information anymore, I have filled a
feature request to upstream.
See:
http://bugzilla.gnome.org/show_bug.cgi?id=488923
Comment 16 Matthew Barnes 2007-10-22 10:31:46 EDT
Created attachment 234131 [details]
PDF printed in gu_IN locale

I believe this is working now in Evolution 2.12, both for single and multi-page
cases.	Closing as RAWHIDE, but please feel free to reopen if I'm wrong.

Note You need to log in before you can comment on or make changes to this bug.