Bug 223020 - Installer cannot handle cert location as directory
Installer cannot handle cert location as directory
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Davis
Corey Welton
:
Depends On:
Blocks: 173427
  Show dependency treegraph
 
Reported: 2007-01-17 11:10 EST by Matthew Davis
Modified: 2007-08-06 11:52 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat500
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 23:04:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Davis 2007-01-17 11:10:43 EST
Description of problem:
If a directory is provided as the location of the satellite cert, the installer
dies.  It should be a bit more tolerant.


Steps to Reproduce:
1. Start install (ie ./install.pl --disconnected --skip-db-population
--skip-db-install)
2. When prompted for a cert give a dir ( /root, /, /etc)

  
Actual results:
* Activating Satellite.
Where is your satellite certificate file? /root
** Loading Satellite Certificate.
Use of uninitialized value in sprintf at install/install_main.pl line 2237.
No data found in ''.


Expected results:
Warning data provided is a dir, not a file.
Comment 1 Mike McCune 2007-04-04 14:28:45 EDT
moving to rhn500s-must and assigning to mdavis
Comment 5 Corey Welton 2007-04-24 13:52:14 EDT
Fails due to blocking bug #237495.  Will retest when that bug is ON_QA
Comment 6 Matthew Davis 2007-04-24 16:10:32 EDT
Fix has been committed for bug #237495
Comment 7 Matthew Davis 2007-04-25 14:53:56 EDT
ON_QA
Comment 8 Corey Welton 2007-05-02 14:10:40 EDT
QA Verified.
Comment 9 Pradeep Kilambi 2007-06-15 16:06:29 EDT
re-verified while installing -40 iso
Comment 10 Brandon Perkins 2007-06-25 23:04:24 EDT
Closed for Satellite 500 Release.

Note You need to log in before you can comment on or make changes to this bug.