Bug 223032 - Confusing gconf key descriptions
Confusing gconf key descriptions
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: brasero (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-17 11:47 EST by Mark Knoop
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-17 15:01:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Knoop 2007-01-17 11:47:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.9) Gecko/20061219 Fedora/1.5.0.9-1.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
The gconf keys at /apps/brasero/config/ are confusing and contraditory.

Key name: cdrdao_disabled
Short description: Enable use of cdrdao
Long description: Whether to use cdrdao for burning or not. Set to true to use it.

This doesn't make sense. The key should be changed to the same syntax as the libburn_{burn,iso,read} keys, eg:

Key name: cdrdao_burn
Short description: Use cdrdao to burn CDs
Long desription: Whether to use cdrdao to burn CDs. Set to true to use it.



Version-Release number of selected component (if applicable):
brasero-0.5.1-2.fc6

How reproducible:
Always


Steps to Reproduce:
1. Open gconf-editor
2. Navigate to /apps/brasero/config/
3. Think WTF?

Actual Results:


Expected Results:


Additional info:
Comment 1 Denis Leroy 2007-01-17 15:01:03 EST
Good point though pretty minor bug. I reported it upstream. Closing as won't
fix, i have no intention on providing a patch for this.

Out of curiosity, you can't use libburn on your setup ?
Comment 2 Mark Knoop 2007-01-17 15:12:45 EST
> Good point though pretty minor bug. I reported it upstream.

Thanks - I wasn't sure where upstream was to report it, ... sf or gnome?

> Out of curiosity, you can't use libburn on your setup ?

I can - I discovered this whilst enabling libburn with gconf-editor. Just out of
curiosity, since libburn is a package requirement, why are the libburn keys not
set to true by default?

And I'm still not sure whether checking the cdrdao_disabled key enables or
disables it (I'm guessing enables).
Comment 3 Denis Leroy 2007-01-19 13:34:59 EST
I reported it to sf (and it got noticed), but it's probably better to file on
bugzilla.gnome

The gconf issue is interesting. And thanks for pointing it out because i had not
noticed it (no doughnut for me, as the packager i'm supposed to know). I thought
the decision to use cdrecord versus libtool was strictly a compile-time one, but
after looking at the code it is not the case. You are right that it will use
cdrecord and cdread by default, and only use libisofs/libtool if any of the
libburn gconf keys are set. I now have to make a decision whether the time has
come to "flip the switch" and migrate it to libburn by default... Maybe for fc-7 ?

Note You need to log in before you can comment on or make changes to this bug.