Bug 223042 - Upgrading selinux-policy-targeted takes forever even with SELinux disabled
Upgrading selinux-policy-targeted takes forever even with SELinux disabled
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-17 12:39 EST by Ed Swierk
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 10:13:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Swierk 2007-01-17 12:39:39 EST
While upgrading a machine from FC4 to FC6, Anaconda hung while installing the
selinux-policy-targeted package.

On virtual terminal 1 I see the following:

---

Starting graphical installation...
No handlers could be found for logger "yum.YumBase"
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 954, in <lambda>
  File "/usr/lib/anaconda/exception.py", line 353, in handleException
  File "/usr/lib/anaconda/gui.py", line 832, in exceptionWindow
  File "/usr/lib/anaconda/gui.py", line 585, in __init__
  File "/usr/lib/anaconda/gui.py", line 403, in findGladeFile
RuntimeError: Unable to find glade file exn.glade

Original exception was:
Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 172, in handleShiftPrintScrnRelease
  File "/usr/lib/python2.4/site-packages/gtk-2.0/gtk/_lazyutils.py", line 32, in
__getattr__
ImportError: No module named keysyms
Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 172, in handleShiftPrintScrnRelease
  File "/usr/lib/python2.4/site-packages/gtk-2.0/gtk/_lazyutils.py", line 32, in
__getattr__
ImportError: No module named keysyms

---

I assume this has left the machine in an inconsistent state, so this is a pretty
severe bug.

Not sure if this is relevant, but I started the install via PXE using the kernel
and initrd in the pxelinux directory of the FC6 install CD.  I passed the
following command-line options from the boot loader:

method=http://mirrors.xxxx.com/fedora/linux/core/6/i386/os lang=en_US keymap=us
Comment 1 Ed Swierk 2007-01-18 12:32:59 EST
I just ran into this problem again while upgrading another machine.  Anaconda
seemed to be hung while installing selinux-policy-targeted, but this time there
were no tracebacks in the log.

It turns out that the install was not hung at all, but a bunch of processes
including "restorecon" and "find" were grinding away for an hour doing
who-knows-what.  I don't want SELinux, don't care whether SELinux works, and in
fact SELinux was disabled completely on that machine before I started the
upgrade.  So I killed those processes and the installation seems to be
proceeding normally now.
Comment 2 Ed Swierk 2007-01-18 13:09:24 EST
If SELinux is disabled anyway, a workaround is simply to remove
selinux-policy-targeted and friends before upgrading:

# yum remove selinux-policy selinux-policy-strict selinux-policy-targeted
Comment 4 Daniel Walsh 2007-04-05 13:54:21 EDT
Fixed in selinux-policy-2.4.6-53

Will no longer relabel if selinux is disabled.
Comment 5 Daniel Walsh 2007-08-22 10:13:45 EDT
Fixed in current release

Note You need to log in before you can comment on or make changes to this bug.