Bug 223064 - rhythmbox ipod support crashes
rhythmbox ipod support crashes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-17 14:01 EST by Juan Manuel Borges Caño
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: rhythmbox-0.9.7-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-02 16:54:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan Manuel Borges Caño 2007-01-17 14:01:31 EST
Description of problem:
If an ipod (nano 2gb) is connected to the usb port, rhythmbox crashes (on
startup or running).

Version-Release number of selected component (if applicable):
0.9.5 (latest)

How reproducible:
Connect an ipod while rhythmbox is running, or execute rhythmbox with an ipod
connected.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
crash

Expected results:
to work

Additional info: there seems that a patch exists for rhythmbox 0.9.4.1, look at
http://bugzilla.gnome.org/show_bug.cgi?id=352972 attachment. Good luck.
Comment 1 Alexander Larsson 2007-01-18 04:47:05 EST
Can you try the updates in testing?
Comment 2 Juan Manuel Borges Caño 2007-01-18 13:35:57 EST
I updated libgpod (to 0.4.0-0), and it works. Thank you.
It seems that the stable libgpod version is too old for ryhthmbox.
For me the bug is pending of a stable release of libgpod compatible with
rhythmbox ipod support.
For now i continue using the testing libgpod version until the stable release.
Comment 3 Alexander Larsson 2007-01-19 03:28:50 EST
libgpod 0.4.0 was never packaged for FC6, because its binary incompatible and
doesn't change soname of the library. Running it without rebuilding all apps
that use it risks segfaults.

The updates-testing version is 0.4.2.
Comment 4 Juan Manuel Borges Caño 2007-01-19 09:14:13 EST
ok, i tried it, and it works with 0.4.2 from updates-testing. Thank you again
for the recommendation.
Comment 5 Peter van Egdom 2007-07-02 16:54:01 EDT
Closing bug. See comment #4. Package "libgpod-0.4.2" is also released with 
Fedora release 7.

Note You need to log in before you can comment on or make changes to this bug.