Bug 223161 - Make sure wireless-tools work with ipw3945 (64bit problems in -28)
Summary: Make sure wireless-tools work with ipw3945 (64bit problems in -28)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: wireless-tools (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: x86_64 Linux
urgent
urgent
Target Milestone: ---
: ---
Assignee: Christopher Aillon
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: Desktop
Depends On: 214060
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-18 02:31 UTC by Daniel Riek
Modified: 2007-11-30 22:07 UTC (History)
5 users (show)

Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-26 03:12:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backport 64-bit sscanf argument fixes from wireless-tools-29-pre8 to wireless-tools-28 (2.30 KB, patch)
2007-01-18 15:03 UTC, Dan Williams
no flags Details | Diff
Diff from wt-29-pre7 to wt-29-pre8 in which sscanf 64-bit fixes were added upstream (20.51 KB, patch)
2007-01-18 15:05 UTC, Dan Williams
no flags Details | Diff

Comment 1 Christopher Aillon 2007-01-18 02:45:49 UTC
John, Dan: Do either of you know about the issues from the original report?

Comment 2 John W. Linville 2007-01-18 11:45:31 UTC
I'm not familiar with the 64-bit issue for wireless-tools <29...Dan?

Comment 3 Dan Williams 2007-01-18 15:02:27 UTC
Only comment I see in the changelog about 64-bit stuff is:

 *	o Add temp variable to sscanf() to fix 64 bits issues [iwconfig]

I've backported this into the patch attached here, and the diff from
wireless-tools-29pre7 to wireless-tools-29pre8 from where I got the original
changes.

I'm a bit concerned about 'rts' and 'frag' sections.  They both use temp
variables of 'long temp' but only 'rts' casts it to (unsigned long *) when
passing it to sscanf().  I'm not sure if that makes a difference or not, but I
checked in wireless-tools-29-pre10 (latest) and the 'rts' casting bits are still
there.

John; can you take a look at see if there are any obvious mistakes?  Can you
also compile on a 64-bit machine and check for warnings?

Comment 4 Dan Williams 2007-01-18 15:03:53 UTC
Created attachment 145922 [details]
Backport 64-bit sscanf argument fixes from wireless-tools-29-pre8 to wireless-tools-28

Comment 5 Dan Williams 2007-01-18 15:05:42 UTC
Created attachment 145923 [details]
Diff from wt-29-pre7 to wt-29-pre8 in which sscanf 64-bit fixes were added upstream

Comment 6 Dan Williams 2007-01-18 15:09:30 UTC
Basically, without a compelling reason, clear feature request, or a bunch of
regression testing, I wouldn't feel comfortable with just revving wireless-tools
up to v29.  I feel like most issues could be resolved fairly easily through
backports since the code is pretty contained and fairly straightforward.

Comment 7 Daniel Riek 2007-01-18 16:12:45 UTC
I agree with the last comment. Please backport. I'll change the summary.

Comment 13 Christopher Aillon 2007-01-18 19:33:22 UTC
Building as wireless-tools-28-2.el5

Comment 18 Zack Cerza 2007-01-24 22:19:01 UTC
Just wanted to note that we can't fully test this fix for regressions because of
bug #224266.

Comment 25 Zack Cerza 2007-01-25 20:42:43 UTC
No problems. The new wireless-tools don't appear to break anything.

Comment 26 Jay Turner 2007-01-26 03:12:54 UTC
wireless-tools-28-2.el5 included in 20070124.1.


Note You need to log in before you can comment on or make changes to this bug.