Bug 2232212 - [Flatpak] Search results box is not large enough on Flatpak build since gnome-maps-stable-3820230613160651.1
Summary: [Flatpak] Search results box is not large enough on Flatpak build since gnome...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-maps
Version: 39
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kalev Lember
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-08-15 19:05 UTC by Adam Williamson
Modified: 2023-08-15 19:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-08-15 19:43:37 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
screenshot from 2023-06-19 test (good) (141.98 KB, image/png)
2023-08-15 19:06 UTC, Adam Williamson
no flags Details
screenshot from 2023-06-22 test (bad) (190.25 KB, image/png)
2023-08-15 19:08 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2023-08-15 19:05:56 UTC
Since https://bodhi.fedoraproject.org/updates/FEDORA-FLATPAK-2023-153d758ea0 landed - I believe - when running the Fedora Flatpak build of GNOME Maps (as is built in to Silverblue installer images), when you type something into the search box, the box that drops down to show the results is far too small. It can only show part of the first result.

I'm attaching screenshots of how it looked in the Fedora-Rawhide-20230619.n.0 test (good, before the update) and how it looked in the Fedora-Rawhide-20230622.n.0 (bad, after the update).

Sorry for the late report of this - I only just noticed it because at first the openQA test still passed, the reduced box still showed enough of the expected result for the needle to match. Some subsequent change - either the box got even smaller, or the results got a bit more whitespace padding - made the test start failing and made me notice this problem, but subsequent investigation showed it really appeared much earlier.

Reproducible: Always

Steps to Reproduce:
1. Run the flatpak build of GNOME Maps (on F39 or F40, I'm not sure this happens on F38 as we don't test that)
2. Search for something, e.g. 'Brno'
Actual Results:  
The results box is way too small and shows only part of the first result

Expected Results:  
The results box should be much taller and show several full results

Comment 1 Adam Williamson 2023-08-15 19:06:59 UTC
Created attachment 1983440 [details]
screenshot from 2023-06-19 test (good)

Comment 2 Adam Williamson 2023-08-15 19:08:13 UTC
Created attachment 1983441 [details]
screenshot from 2023-06-22 test (bad)

Comment 3 Adam Williamson 2023-08-15 19:43:37 UTC
Moved to https://gitlab.com/fedora/sigs/flatpak/fedora-flatpaks/-/issues/21 .


Note You need to log in before you can comment on or make changes to this bug.