Bug 22323 - Only 64 Mb out of 192 Mb recognized on Thinkpad 600x
Summary: Only 64 Mb out of 192 Mb recognized on Thinkpad 600x
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-15 02:29 UTC by CJeness
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 22:48:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description CJeness 2000-12-15 02:29:09 UTC
I have a ThinkPad 600x with 192 Mb of memory; however, RedHat linux 7.0 is
only recognizing 64 Mb.  Here is the output from "/proc/meminfo".  This is
a dual boot machine and the other operating system does recognize the
memory.  Also, the correct amount is reported from the hardware as part of
a cold boot.

Mem:  65478656 64032768  1445888 53014528  1396736 14565376
Swap: 270909440  7618560 263290880
MemTotal:     63944 kB
MemFree:       1412 kB
MemShared:    51772 kB
Buffers:       1364 kB
Cached:       14224 kB
BigTotal:         0 kB
BigFree:          0 kB
SwapTotal:   264560 kB
SwapFree:    257120 kB

Comment 1 K2 2000-12-15 06:06:28 UTC
You should add line 
 	append="mem=192M"
 in the /etc/lilo.conf and make /sbin/lilo -v

boot=/dev/sda
      map=/boot/map
      install=/boot/boot.b
      prompt
      timeout=50
      image=/boot/vmlinuz-2.2.12-20
              label=linux
              root=/dev/sda1
              initrd=/boot/initrd-2.2.12-20.img
              read-only
              append="mem=192M"	

http://www.redhat.com/support/docs/faqs/rhl_general_faq/FAQ-7.html#ss7.1
Hope it will help to solve the problem



Comment 2 Arjan van de Ven 2001-01-16 16:53:05 UTC
The root of this problem is caused by the bios not being 100% compatible to the
standard.
In the 2.4.0 kernel, a fix was found for this, and this fix will probably be
incorporated in the 
2.2.19 kernel as well.


Note You need to log in before you can comment on or make changes to this bug.