Bug 223230 - clustat has bizarre output when qdisk is in use
Summary: clustat has bizarre output when qdisk is in use
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager   
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
: 311201 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-18 15:59 UTC by Lon Hohberger
Modified: 2018-10-19 23:32 UTC (History)
3 users (show)

Fixed In Version: RHBA-2007-0580
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 16:45:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0580 normal SHIPPED_LIVE rgmanager bug fix and enhancement update 2007-10-30 15:37:24 UTC

Description Lon Hohberger 2007-01-18 15:59:51 UTC
Description of problem:

[root@war ~]# clustat
/dev/sdd1 not found
realloc 1232
Member Status: Quorate

  Member Name                        ID   Status
  ------ ----                        ---- ------
  war.lab.boston.redhat.com             1 Online, Local
  pestilence.lab.boston.redhat.com      2 Offline
  famine.lab.boston.redhat.com          3 Offline
  /dev/sdd1                             0 Online, Estranged

Version-Release number of selected component (if applicable):

How reproducible: 100%

Steps to Reproduce:
1. configure qdisk
2. start qdisk + cman
3. run 'clustat'
  
Actual results: above.

Expected results: uncertain.... maybe:

[root@war ~]# clustat
Member Status: Quorate

  Member Name                        ID   Status
  ------ ----                        ---- ------
  war.lab.boston.redhat.com             1 Online, Local
  pestilence.lab.boston.redhat.com      2 Offline
  famine.lab.boston.redhat.com          3 Offline

  Quorum Device
  ------ ------
  /dev/sdd1                           N/A Online

Additional info:

Comment 1 Lon Hohberger 2007-01-26 20:43:09 UTC
Instead used:

[root@war rgmanager]# src/utils/clustat
Member Status: Quorate

  Member Name                        ID   Status
  ------ ----                        ---- ------
  war.lab.boston.redhat.com             1 Online, Local
  pestilence.lab.boston.redhat.com      2 Online
  famine.lab.boston.redhat.com          3 Online
  /dev/sdb1                             0 Online, Quorum Disk

[root@war rgmanager]# src/utils/clustat -x
<?xml version="1.0"?>
<clustat version="4.1.1">
  <quorum quorate="1" groupmember="0"/>
  <nodes>
    <node name="war.lab.boston.redhat.com" state="1" local="1" estranged="0"
rgmanager="0" qdisk="0" nodeid="0x00000001"/>
    <node name="pestilence.lab.boston.redhat.com" state="1" local="0"
estranged="0" rgmanager="0" qdisk="0" nodeid="0x00000002"/>
    <node name="famine.lab.boston.redhat.com" state="1" local="0" estranged="0"
rgmanager="0" qdisk="0" nodeid="0x00000003"/>
    <node name="/dev/sdb1" state="1" local="0" estranged="0" rgmanager="0"
qdisk="1" nodeid="0x00000000"/>
  </nodes>
</clustat>

Fixes in CVS:

http://sourceware.org/cgi-bin/cvsweb.cgi/cluster/rgmanager/src/utils/clustat.c.diff?cvsroot=cluster&only_with_tag=RHEL5&r1=1.25.2.2&r2=1.25.2.3


Comment 2 Kiersten (Kerri) Anderson 2007-04-23 17:24:20 UTC
Fixing Product Name.  Cluster Suite was integrated into the Enterprise Linux for
version 5.0.

Comment 4 RHEL Product and Program Management 2007-05-01 17:34:07 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 7 Lon Hohberger 2007-06-29 17:19:18 UTC
Self-evident.

Minimally, clustat claims that the qdisk device is 'estranged'.  In some cases,
it may have garbage following the device name in clustat output.

Comment 8 Nick Strugnell 2007-09-28 15:50:18 UTC
*** Bug 311201 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2007-11-07 16:45:33 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0580.html



Note You need to log in before you can comment on or make changes to this bug.