Bug 223302 - RelaxNG schema does not allow option for APC fence devices
Summary: RelaxNG schema does not allow option for APC fence devices
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: redhat-config-cluster   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-18 21:56 UTC by Bryn M. Reeves
Modified: 2018-11-14 18:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 14:38:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch adding optional "option" attribute for APC devices (547 bytes, patch)
2007-01-18 21:56 UTC, Bryn M. Reeves
no flags Details | Diff
cluster.conf with redundant APC devices (1.56 KB, text/plain)
2007-01-18 22:00 UTC, Bryn M. Reeves
no flags Details

Description Bryn M. Reeves 2007-01-18 21:56:06 UTC
Description of problem:
If a pair of APC power switches is used in a redundant configuration, the
"option" attribute is needed to power both "off" and then "on" again.
System-config-cluster automatically generates correct XML for this when such a
configuration is entered.

Re-loading this XML causes a RelaxNG error dialog as the schema does not allow
the "option" attribute for the APC devices.

Version-Release number of selected component (if applicable):
system-config-cluster-1.0.27

How reproducible:
100%

Steps to Reproduce:
1. Configure two APC fence devices
2. Add both devices to a fence level for a redundant configuration
3. Save configuration
4. Close tool
5. Re start system-config-cluster

Actual results:
RelaxNG error dialog:
$ xmllint --noout --relaxng /usr/share/system-config-cluster/misc/cluster.ng
cluster-26.conf
Relax-NG validity error : Extra element fence in interleave
cluster-26.conf:4: element clusternodes: Relax-NG validity error : Element
clusternode failed to validate content
cluster-26.conf:5: element clusternode: Relax-NG validity error : Element
clusternodes has extra content: clusternode
cluster-26.conf:6: element multicast: Relax-NG validity error : Element
clusternode has extra content: multicast
cluster-26.conf:2: element cluster: Relax-NG validity error : Invalid sequence
in interleave
cluster-26.conf:2: element cluster: Relax-NG validity error : Element cluster
failed to validate content
cluster-26.conf:9: element device: validity error : IDREF attribute name
references an unknown ID "foo01p2"
cluster-26.conf:9: element device: validity error : IDREF attribute name
references an unknown ID "foo01p2"
cluster-26.conf:9: element device: validity error : IDREF attribute name
references an unknown ID "foo01p2"
cluster-26.conf:9: element device: validity error : IDREF attribute name
references an unknown ID "foo01p2"
cluster-26.conf fails to validate


Expected results:
Succesful start up / no RelaxNG errors.

Additional info:

Comment 1 Bryn M. Reeves 2007-01-18 21:56:09 UTC
Created attachment 145947 [details]
Patch adding optional "option" attribute for APC devices

Comment 3 Bryn M. Reeves 2007-01-18 22:00:07 UTC
Created attachment 145948 [details]
cluster.conf with redundant APC devices

Comment 4 Jim Parsons 2007-01-19 01:33:54 UTC
Thanks - this was an oversight. All fences should have this attribute, so I will
add to the outer group in the validation file. 

One additional comment: The gui sets up the options for you when configuring
redundant power supply fencing.

Also, when loading the conf file in the app, a workaround for this issue is
simply to click thru the warning message and continue.

Comment 5 Jim Parsons 2007-02-09 20:26:08 UTC
all set. will be in 4.5, and prolly 5.1

Comment 8 Jim Parsons 2007-09-25 14:38:39 UTC
Yes it did. This went out already. This work was done under a different relaxng
schema bug, so marking as not a bug.


Note You need to log in before you can comment on or make changes to this bug.