Bug 22339 - kickstart redhat 7.0 problem
kickstart redhat 7.0 problem
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-15 05:58 EST by TONUS Benjamin
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-04 14:42:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description TONUS Benjamin 2000-12-15 05:58:36 EST
I use Kickstart with 64 PC under Redhat 6 / bootp and i don't have a
problem.
but with redhat 7 :(

->I make a boot disk :
dd if=bootnet.img od=/dev/fd0 bs=72k

->and i copy ks.cfg generated by mkkickstart under floppy: 
mcopy ks.cfg a:

->ks .cfg:

lang fr_FR
network --bootproto bootp
cdrom
device ethernet eepro100
keyboard "fr-latin1"
zerombr yes
clearpart --linux
part swap --size 503
install
mouse genericps/2
timezone Europe/Paris
xconfig --server "Mach64" --monitor "generic monitor"
rootpw --iscrypted $1$pKxVHPvf$vxQEWndqCC3pmEQmzkFIE1
auth --useshadow
lilo --location mbr

%packages
glibc
libtermcap
fileutils
e2fsprogs
sysklogd
modutils
textutils
cracklib
db3
chkfontpath
db1
sh-utils
.
.
.
sysreport
unarj
ytalk

%post

->linux ks=floppy
->And when i boot with the disk the system write "no install method
specified for kickstart"
But the file ks.cfg is known by the sytem because it write : "kickstart
file copied to /tmp/ks.cfg".
(i see this message with the virtual cnsole [ctrl] + F3.)

->linux ks
-> Under redhat6 i use bootp : the file ks.cfg is on the server and under
the install kickstart
mount by nfs le file. But with redhat7 the systeme can't mount the file.

I think may be is the bootnet.img is wrong , i don't kwnow. But i hope
HELP.
Thank
and sorry for my bas Englih. :=)
Comment 1 Matt Wilson 2001-01-29 13:51:24 EST
you're trying to use "cdrom" as the method on a bootnet.img disk?
Comment 2 TONUS Benjamin 2001-01-30 03:59:38 EST
I use a bootnet image because i need network interface(Bootp) for get the ks.cfg
in a central server.
After, i use a cdrom on a local machine.


Comment 3 Matt Wilson 2001-01-30 07:59:27 EST
But with red hat linux 7 you say that you copied ks.cfg to the floppy.
Comment 4 TONUS Benjamin 2001-01-30 12:07:43 EST
sorry, i think my explain is not good:
My principal use is :
a server with bootp(configuration network of workstation) and a ks.cfg.
when i lauch a reinstall of a workstation with a floppy,(linux=ks) the
workstation get the network configuration with bootp and get ks.cfg on the
server. After, it install the packages with the local cdrom.
this work perfecly with redhat6.

In my past explain i say i copy ks.cfg to floppy, because i try with network and
as it don't work i try with the file direcly on a disk.


Note You need to log in before you can comment on or make changes to this bug.