Bug 223468 - HTS: network test failed if hts certify --server [ipaddress] was run
HTS: network test failed if hts certify --server [ipaddress] was run
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-19 11:13 EST by Garry Wong
Modified: 2008-07-16 18:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: hts-5.0-21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-01 22:45:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This test results 3 which network test failed (1.16 MB, application/octet-stream)
2007-01-19 11:13 EST, Garry Wong
no flags Details
This is test results that network test passed (2.04 MB, application/octet-stream)
2007-01-19 11:16 EST, Garry Wong
no flags Details
This test results 3 which network test failed (1.16 MB, application/octet-stream)
2007-01-19 11:18 EST, Garry Wong
no flags Details
failing network test run with R17 on DL320G5 (2.95 MB, application/octet-stream)
2007-01-23 15:45 EST, Gregory Feiner
no flags Details
Passing network test run with R17 on DL320G5 (1.79 MB, application/octet-stream)
2007-01-23 15:46 EST, Gregory Feiner
no flags Details
System Log during Test Failure (1.68 KB, text/plain)
2007-01-23 16:42 EST, Greg Nichols
no flags Details

  None (edit)
Description Garry Wong 2007-01-19 11:13:51 EST
Description of problem:

Network test would fail if "hts certify --server [ipaddress]" was run, but 
would pass if running by itself with command hts certify --test network --
server [ipaddress]

Version-Release number of selected component (if applicable):

rhel5 hts R17


How reproducible:


Steps to Reproduce:

1. Install rhel5 x64 initial release with Virtualization capability onto 
system under test -ProLiant DL360 G4
2. Install rhel5 x64 initial release onto network test server
3. Install rhel5 hts version 5 release 17 test suite onto both system under 
test and network test server (with IPV4 status ip address 10.1.1.10)
4. On network test server ---> lat_tcp -s ---> hts  server start
5. On system under test ----> lat_tcp 10.1.1.10 --> hts plan ----> hts 
certify --server 10.1.1.10 ----> network test failed (see attached test 
results 3)
6. On system under test ---> hts certify --test network --server 10.1.1.10 ---
> network test passed (see attached test results 4)

Actual results: -When using "hts certify --server 10.1.1.10" to run all tests, 
network test failed
-When using "hts certify --test network --server 10.1.1.10" to run network 
test only, the test passed.


Expected results: Should pass either case


Additional info:
Comment 1 Garry Wong 2007-01-19 11:13:52 EST
Created attachment 145998 [details]
This test results 3 which network test failed
Comment 2 Garry Wong 2007-01-19 11:16:31 EST
Created attachment 145999 [details]
This is test results that network test passed

This is test results that network test passed
Comment 3 Garry Wong 2007-01-19 11:18:06 EST
Created attachment 146000 [details]
This test results 3 which network test failed

Resent test results 3
Comment 4 Gregory Feiner 2007-01-19 14:41:52 EST
I ran the network test multiple times on a DL320 G5 using R17.  Each time I 
used "hts certify --test=network --server=10.0.0.127"  The test passed the 
first time and the logs showed results for both nics, but on subsequent 
attempts using the same command line, the test failed and the logs only showed 
results for one nic even though results "on screen" showed both nics were 
tested.
Comment 5 Greg Nichols 2007-01-23 15:38:29 EST
(In reply to comment #4)
> I ran the network test multiple times on a DL320 G5 using R17.  Each time I 
> used "hts certify --test=network --server=10.0.0.127"  The test passed the 
> first time and the logs showed results for both nics, but on subsequent 
> attempts using the same command line, the test failed and the logs only showed 
> results for one nic even though results "on screen" showed both nics were 
> tested.

Please attach these test results.

- Thanks!
Comment 6 Gregory Feiner 2007-01-23 15:45:21 EST
Created attachment 146351 [details]
failing network test run with R17 on DL320G5
Comment 7 Gregory Feiner 2007-01-23 15:46:06 EST
Created attachment 146352 [details]
Passing network test run with R17 on DL320G5
Comment 8 Greg Nichols 2007-01-23 16:42:06 EST
Created attachment 146362 [details]
System Log during Test Failure
Comment 9 Greg Nichols 2007-01-23 16:43:31 EST
(In reply to comment #8)
> Created an attachment (id=146362) [edit]
> System Log during Test Failure
> 

The attached system logs seem to indicate something's amiss during 
the tests.
Comment 10 Greg Nichols 2007-01-23 16:45:02 EST
I can not reproduce problems with settings of the --server option 
interacting with the --test option.
Comment 11 Ronald Pacheco 2007-01-24 12:21:30 EST
Greg,

HP wants to know which server us used.
Comment 12 Garry Wong 2007-01-24 12:52:23 EST
The problem is when you run ALL tests at once by using "hts certify --test 
network --server 10.1.1.10", the network test failed. BUT if you just run 
network test itself by using "hts certify --test network --server 10.1.1.10",
the network test passed.

The system under test is Proliant DL365 or DL360 G5.

When you said you could not reprod, which command you used ?"hts certify --
test network --server ipaddress" or "hts certify --test network --server 
ipadsress" ?

Thanks
 
Comment 13 Greg Nichols 2007-01-24 18:08:52 EST
I've duplicated what you've seen, and verified a fix.

The test server uses lmbench, and its servers shut down after an hour
if there is no activity.  Since the full test runs more than an hour 
before the network portion is run, the lmbench tools have shut down
by the time the server runs.

We've patched lmbench to remove this "feature", so that it does not
shutdown.  This version (lmbench-3.0a7-5.EL5) should be available shortly
on the Partners site.
Comment 14 Garry Wong 2007-01-26 10:23:44 EST
I verified the version lmbench-3.0a7-5.EL5 and it works.

Thanks,

Note You need to log in before you can comment on or make changes to this bug.