Bug 223488 - yum-skip-broken makes weird decisions, and fails to skip the correct packages
yum-skip-broken makes weird decisions, and fails to skip the correct packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-19 12:57 EST by Ralf Ertzinger
Modified: 2014-01-21 18:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 12:14:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Console output of the above commands (69.24 KB, text/plain)
2007-01-19 12:57 EST, Ralf Ertzinger
no flags Details

  None (edit)
Description Ralf Ertzinger 2007-01-19 12:57:05 EST
Description of problem:
Please see the attached console log for details.
I tried to update to current rawhide today, which had a missing dependency. The
current (not updated) package state is listed in the file, too.

yum --obsoletes upgrade
fails (missing dep)

yum --obsoletes upgrade --ignore-broken
fails quite strangely, with a missing glibc dep (huh?)

The correct solution would be to skip the directfb update, as shown by
yum --obsoletes upgrade --exclude directfb


Version-Release number of selected component (if applicable):
yum-skip-broken-1.0.1-1.fc7

How reproducible:
Always (in this particular configuration)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ralf Ertzinger 2007-01-19 12:57:05 EST
Created attachment 146012 [details]
Console output of the above commands
Comment 2 Tim Lauridsen 2007-01-26 09:00:56 EST
it dont looks like a problem with in the plugin, the 
Error: No Package Matching glibc.i686
message is caused by a exception in the yum packageSack(returnNewestByNameArch).

The exception occours when depsolver tries to solve dependencies for 
glibc-common.i386 0:2.5.90-15

the following command should should give the samme error, without skip-broken i
s running.
 
yum --obsoletes upgrade glibc-common

it look like that glibc.i686 cant be found in the packageSack, this is very
strange .

The depcheck for glibc.i686 0:2.5.90-15, has been done for already
so i should be in packageSack.

--> Populating transaction set with selected packages. Please wait.
---> Package glibc.i686 0:2.5.90-15 set to be updated
--> Running transaction check
--> Processing Dependency: glibc-common = 2.5.90-15 for package: glibc
--> Processing Dependency: glibc = 2.5.90-14 for package: glibc-headers
--> Processing Dependency: glibc = 2.5.90-14 for package: glibc-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package glibc-common.i386 0:2.5.90-15 set to be updated
---> Package glibc-devel.i386 0:2.5.90-15 set to be updated
---> Package glibc-headers.i386 0:2.5.90-15 set to be updated
--> Running transaction check

Dont know what can be done to solve the issue, maybe there is bug in the
dependency section for the glibc-common spec.

There is also some issues in the yum code, the traceback should be catched by
the depsolver and reported as a normal dep error.


Comment 3 Tim Lauridsen 2007-02-07 06:56:31 EST
Look like the depsolving of glibc.i686 not only is giving problems when running
skip-broken.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=227603

https://www.redhat.com/archives/fedora-test-list/2007-February/msg00317.html
Comment 4 Tim Lauridsen 2008-03-12 12:14:03 EDT
yum >= 3.2.10 in current rawhide have much improved '--skip-broken' buildin, so
please try 

yum remove yum-skip-broken
yum install pygpgme
yum install --enablerepo=development update yum

to check it out. 

Note You need to log in before you can comment on or make changes to this bug.