Bug 223509 - pirut removes the kernel
pirut removes the kernel
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-19 14:39 EST by Forrest Taylor
Modified: 2013-01-10 05:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 16:45:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Forrest Taylor 2007-01-19 14:39:25 EST
Description of problem:
When selecting certain items, pirut removes the kernel.


Version-Release number of selected component (if applicable):
pirut-1.2.10-1.el5

How reproducible:
Always

Steps to Reproduce:
1.  Run pirut
2.  Deselect certain packages
  
Actual results:
The dependencies will include the kernel.  If you are not careful, you would
destroy your system.


Expected results:
pirut should not uninstall the kernel.  It's a GUI, so at the very least it
should be put in a separate list with big warning signs.  In RHEL up2date always
excluded the kernel for update (let alone removal).

We should really warn people when they are going to have an unusable system.


Additional info:
The following packages, when deselected in pirut, will also remove the kernel:

cracklib
cracklib-dicts
e2fsprogs
e2fsprogs-libs
dmraid
device-mapper
db4
cpio
bzip2-libs
bash
basesystem
audit-libs
ethtool
filesystem
findutils
gawk
gdbm
glib2
glibc
glibc-common
gzip
and so on...
Comment 1 Jeremy Katz 2007-01-29 13:57:22 EST
There is a blacklist of "can't return from here" that we throw up a big and
scary warning about breaking your system.  The problem with kernel is that it
could well be being removed if you've got kernel-xen or kernel-PAE installed as
well.  

So I'm not against extending the blacklist, I just want to make sure we're okay
with what it actually means...
Comment 2 Forrest Taylor 2007-01-29 14:08:05 EST
Not that I have any say here, but I think that we should err on the side of
caution.  It is a GUI, so it is likely that there will be users that use the
app, not knowing exactly what it is doing.  If I were an advanced user, I would
know that I can safely ignore the error because I have a different kernel.

I think that it is important that we let the users know if they have the
potential to destroy their system, like remove the kernel.
Comment 3 Forrest Taylor 2007-01-29 14:11:47 EST
In fact, is there a reason that we don't include Base and Core from comps.xml?
Comment 4 Jeremy Katz 2007-01-29 14:12:39 EST
(In reply to comment #3)
> In fact, is there a reason that we don't include Base and Core from comps.xml?

Because there are a lot of packages there (especially in Base) which are
perfectly valid to remove.
Comment 5 Jeremy Katz 2007-04-09 16:45:00 EDT
Added kernels to pirut-1.3.5

Note You need to log in before you can comment on or make changes to this bug.